FORUMS
Remove All Ads from XDA

 View Poll Results: How U like my 1st post?

Awesome
 
175 Vote(s)
53.52%
Not bad
 
48 Vote(s)
14.68%
Good
 
65 Vote(s)
19.88%
Awful
 
39 Vote(s)
11.93%

[FIX][SOLVED]Status 7 Error with CWM or TWRP Recovery on Rooted Android!

n/a posts
Thanks Meter: 0
 
By AndroTix, Guest on 11th November 2013, 08:43 PM
Post Reply Email Thread
13th March 2014, 06:58 AM |#11  
Junior Member
Thanks Meter: 4
 
More
Unhappy Error 7 installing zipped .apk
I tried installing "incoming_call_notif_I9500.zip" to my GT-I9500 and got the error 7 Using Philz 6.19.3 but there is no assert line at all in the updater script. How to proceed ?
13th March 2014, 07:22 PM |#12  
Junior Member
Thanks Meter: 4
 
More
Unhappy Error 7
I noted that since rooting my GT-I9500 using the Desamsugnizer method:
http://forum.xda-developers.com/show....php?t=2655544

I cannot install any .zip files, just error 7 for anything I try to install whether flashable zips or ROMs, is this a fault of this method or I just pick the wrong files ? The flashable zip doesn't have an assert line. I'm using Philz 6.19.3, could this be the problem ?
Thanks
17th March 2014, 05:34 AM |#13  
Member
Thanks Meter: 4
 
More
I'm with a strange issue here.
I Can't change my recovery!

I'm on CWM 6.0.4.5 (updated of 5.8.0.4) and i'm trying to update but with no success.

First was showing the error 7 and with this tutorial and others posts it was solved.

Now the installation finishes but nothing happens. Rebooting recovery and continue with 6.0.4.5.
Even latest versions (which not have the error) is not installing. I mean, the installation finishes but no recovery is installed.

Someone has passed through this?
28th March 2014, 05:43 AM |#14  
Junior Member
Thanks Meter: 1
 
More
Im having similar problem on my xperia s..im using CWM 6.0.3.2
I edited the script file and followed the steps, but now it says installation aborted
when ever i try to load it.
7th April 2014, 03:24 AM |#15  
Junior Member
Flag Lake Charles
Thanks Meter: 7
 
More
Quote:
Originally Posted by AndroTix

When installing certain custom ROMs on rooted Android smartphones or tablets, you will encounter “Status 7″ error issues once in awhile with ClockworkMod (CWM) Recovery.

Status 7 error is caused while the ROM’s updater script file checks to see if the phone model of your phone is compatible with the ROM you are installing, called “asserts”.

“Asserts” is a safety mechanism so you don’t accidentally install another phone model ROM on your phone. E.g. You tried to install Galaxy S2 ROM on a Galaxy S3 and ending up hard-bricking your phone but you got Status 7 error which saved you.

Now, this safety mechanism is great but there are times where even if you have the correct ROM for your phone, you will get Status 7 error.

This is due to an error by the developer of the ROM in the updater script, causing havoc, making people install another custom recovery like TWRP recovery for no reason.

You can fix the issue by installing TWRP recovery but if you need to restore your CWM backups later down the line, you will have to re-install CWM recovery, causing a big hassle.

Also, if you update to the latest CWM Recovery using ROM Manager, usually this problem is fixed.

But what if you did update to the latest CWM Recovery and still happens? And yes, it does happen even when you update your CWM recovery.

If you simply don’t want to change your recovery (because if it ain’t broke, don’t fix it) or you still get Status 7 error after changing recovery, you can simply edit the updater script yourself to get rid of the asserts.

All you need is a computer and a zipping program! (You might be able to even do it on your Android device with AndroZip and text editor but I haven’t tried yet.)
MAKE SURE THE ROM YOU ARE INSTALLING IS COMPATIBLE WITH YOUR ANDROID DEVICE AS INSTALLING WRONG ROM CAN BRICK YOUR DEVICE!

Before we begin, e.g. Make sure if you are installing a ROM on AT&T Galaxy S3, the ROM zip file you downloaded is for AT&T Galaxy S3 not for Verizon Galaxy S3.


Step 1. Copy the ROM zip file to your computer and extract it using your favorite unzipping software.


.................................................
Step 9. Try re-installing ROM, now it should install fine without Status 7 error.

I signed and wrote my app using Android Kitchen. For my "assert" lines, there is not "getprop" command. here is my "assert" commands:

assert(package_extract_file("boot.img", "/tmp/boot.img"),
write_raw_image("/tmp/boot.img", "/dev/block/mmcblk0p20"),
delete("/tmp/boot.img"));

AND

assert(package_extract_file("modem.bin", "/tmp/modem.bin"),
run_program("/tmp/flash_image", "/dev/block/mmcblk0p2", "/tmp/modem.bin"),
delete("/tmp/modem.bin"));

Should I delete both, only one, or neither?
The Following User Says Thank You to jlandry287 For This Useful Post: [ View ] Gift jlandry287 Ad-Free
21st April 2014, 08:10 PM |#16  
lorjay589's Avatar
Senior Member
Flag Baltimore, MD
Thanks Meter: 2,663
 
Donate to Me
More
you can also get an error 7 if there's something on the script thats not present in the build that its telling it to do like package_extract_file("system/bin/backuptool.sh", "/tmp/backuptool.sh"); it wasn't in the bin folder so it kept aborting.
But not just that file specifically. you have to really check the updater script. and you don't have to rename updater script to
open as a text file. you can open with notepad++
4th May 2014, 09:14 PM |#17  
Member
Thanks Meter: 2
 
More
Quick question. I attempted to install stock Sprint FW, and got a status 7 in the recovery. Install aborted and I can't seem to get back into the recovery.. Any ideas? Thanks

Basically when I boot it up it stays at the Samsung Galaxy S3 screen

edit: nvm I got back into Philz recovery..
3rd June 2014, 10:32 AM |#18  
pfufle's Avatar
Senior Member
Thanks Meter: 265
 
More
i was getting the status 7 error with cwm 6.0.4.7...i installed philz recovery (cwm base: 6.0.4.8 ) and i was able to get past this dreaded error...thanks...
10th June 2014, 06:16 PM |#19  
Junior Member
Thanks Meter: 1
 
More
Thumbs up
Great. I finally flashed my rom successfully. Thanks for your helpful post.
29th June 2014, 01:44 PM |#20  
Junior Member
Thanks Meter: 1
 
More
Tablet
Not working for me
3rd July 2014, 06:38 PM |#21  
Senior Member
Flag Kandy
Thanks Meter: 36
 
More
not working
did as mentioned...now im getting another error..status 4
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes