Remove All Ads from XDA

[Q] Unlocked 920 won't register with cellular network

11 posts
Thanks Meter: 1
By gwydionjhr, Junior Member on 4th May 2014, 10:22 PM
Post Reply Email Thread
I have an AT&T 920 that I bought 2nd hand and got unlocked.

I've unlocked a half dozen WPs, all originally Canadian phones, this was my first U.S. carrier phone. I went through the same procedure, non-carrier SIM, enter code, etc. And it appeared to have worked, but I tried two different SIMs and the phone wouldn't register with the network.

OK, so maybe some more fiddling is in order..

I then went through the procedure using the NCS to re-brand the phone to Rogers RM-820.

Once the Rogers ROM was installed, I had access to the diagnostics, including checking the status of the SIM unlock. Which showed as still locked. So I entered the unlock code I had, and now the phone shows as SIM unlocked.

I've also tried a different SIM tray for a 920 with no luck.

All of the above still did not solve the problem.

The phone "sees" the available networks. (Fido, Telus, Bell) But it won't register with them.

As the phone has a cracked screen, and I have a replacement for it, and I'm going to be opening it up, is there something physical I can check on the phone while I'm in there?

Is there anything in the diagnostics I should be looking for?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes