Remove All Ads from XDA

[Q] Input Issues and Data Connection Drops

3 posts
Thanks Meter: 0
By Mirudus, Junior Member on 5th May 2014, 10:26 PM
Post Reply Email Thread
Hey there.

I have a stock Samsung Galaxy S4 Active on the AT&T network. Recently, I've been plagued by a number of troubles.

Bit of background:
For a while, I had the most bizarre issue: the screen thought I was touching it when I wasn't, near the bottom-middle of the screen, and would attempt to open/click on anything in that area. Often turning the screen on and off would help, for a little while. I was reaching my wits' end, because that would obviously be very frustrating to someone who uses their phone frequently throughout the day.

I thought maybe it had been new software I had installed, so I did a factory reset. Problem remained. I factory reset with NO backups. Problem remained. I updated to 4.4.2 via OTA. Problem remained...

And then mysteriously went away on its own.

I've been working in tech for a decade now, mainly in PC and server architecture, so I know better than to look a gift horse in the mouth - but I also know better than to think a problem that "mysteriously" goes away is gone for good. So the first part of my question: does anyone know what could have possibly been causing this?

I'm not super phone-savvy. I've rooted and flashed a few phones in the past couple years, but I'm by no means developer-level.


Which brings me to my next problem... around the time that this issue went away, another one cropped up. Randomly, my phone will stop sending/receiving texts/calls, and the data connection will not function. This will continue until I turn on airplane mode and turn it off--at that point I receive all my missed texts, and it works again... sometimes for 5 minutes, sometimes for nearly 2 days. It's really frustrating. I've tried factory resets, I've tried restoring default APNs... but I'm at my wit's end with this. Can anyone help?

5th May 2014, 10:56 PM |#2  
OP Junior Member
Thanks Meter: 0
I should add that, with my last issue, it still shows a data connection in the notification bar - but there is none, or at least, no activity on it. It doesn't simply act as if it's in airplane mode and go "wah no data network" as soon as I try using it--it just simply hangs for ~30 seconds, then times out. Messages don't get received, webpages don't load, calls don't get placed, etc.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes