Remove All Ads from XDA

[Q] Looking for CWM porting help

43 posts
Thanks Meter: 5
Post Reply Email Thread
I have been working tirelessly on getting a working CWM recovery built from source to work on this device. The device is the BLU Studio 5.5, also known as the 'd610'. I am attempting to compile from the cm-10.1 branch

My current device tree for the device can be found here.

What I have tried so far:
-modifying and recovery.fstab to match what I am able to pull from the device and adding the init.rc and its dependencies into the recovery build (did not boot)
-building the recovery of another very similar MTK6589 device and using the kernel pulled from the d610 instead. (did not boot)
-forked the device tree of this very similar device, and made slight modifications to BoardConfig for my device, as well as swapping the kernel (again, did not boot)

I have absolutely no idea what is going wrong in my process. All of the builds of CWM compile fine, and are being flashed via mtk-tools just fine. Though something is not allowing these builds to boot into recovery. I think I may be missing some important information on the MTK6589 or Mediatek in general.

Thank you for any input you guys can offer.

Also, if I am in the wrong section, if a moderator could kindly place it in the correct section, that would be great!
5th May 2014, 11:36 AM |#2  
Senior Member
Flag Wrocław
Thanks Meter: 964
Donate to Me
From a quick glance I can tell you are missing ramdisk address offset, these are are usually hardcoded in the BL, you can check the address from boot image header

Sent from my LG-D605 using Tapatalk
5th May 2014, 08:15 PM |#3  
OP Member
Flag Fullerton, California
Thanks Meter: 5
Donate to Me
Okay I will be adding that in here shortly. I haven't seen that flag used very often in BoardConfig when I look at other device trees. Is it possible that anyone could explain why some devices may need the flag while others don't?

And again thank you for your response!

EDIT: added ramdisk offset arguments, and still no luck on getting the recovery to boot.

Sent from my Nexus 5 using XDA Free mobile app
6th May 2014, 07:57 AM |#4  
OP Member
Flag Fullerton, California
Thanks Meter: 5
Donate to Me
Update: I am trying to unpack my recovery.img files after compilation using these scripts, which have always worked for me in the past. Now that I am trying to unpack after these are built, I am finding that they are unable to detect the ramdisk in the recovery.img. I think this may be because the ramdisk may be in the wrong place. Though I have built the recovery with and without the offset flags, and still it cannot detect the ramdisk.

Also, I pushed more of the proper files that were pulled from the stock recovery.

I have also decided that I am willing to offer a small bounty to anyone that wants to help me find the solution along with some explanation of where it went wrong.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes