Remove All Ads from XDA

[Q] Strange boot problem. Battery empty loop.

194 posts
Thanks Meter: 80
By fa-schmidt, Senior Member on 6th May 2014, 12:08 PM
Post Reply Email Thread
Hi all!

So now i have this strange boot problem.

My i9000 came on FRoYO with totally drained battery. I charged to full and then could turn the phone on.
It connected to my WLAN and everything seemed fine. I did not test with my SIM card inserted but thought it would not be necessary because
i wanted to root it anyway.

So i got heimdall on my Linux and followed the instructions given here:

I flashed the XWJVZ version and it seemed to be o.k. like above.
Now i followed the instructions on Cyanogen website on how to root the phone.
I got the Semaphore recovery kernel flashed and the CM11 M5 snapshot plus gaaps.
Everything turned out to be fine but only with the charger connected or the usb into the pc.

Finally i got everything up and running and inserted my SIM card and booted up again.
This time without charger.
I noticed the "empty battery symbol" flashing twice, blank screen, flashing etc..
Connected the charger, it starts charging and shows 90% charge.
Disconnected the charger. Booted, Everything fine.

So i began to read about the problem and tried a few things.
I used the battery from my second i9000, which is on CM10.2 running nicely.
I cleaned the battery contacts and the usb.
I re-inserted SIM several times.
No avail.
The phone sometimes shows empty battery but boots up on looong press of power on.
But anytime there is no cell communication, it shows "no baseband" and no IMEI.
I can connect a charger or a usb on the pc and -poof- SIM PIN is required to get on and everything is fine.
Baseband is shown. Correct IMEI as well.

So i thought maybe something had gone wrong during flashing. I removed "batterystats-files".
I wiped everything and flashed again.
I downgrade to stock rom with heimdall, see above and tested with SIM.
It seemed to be o.k. but i have to admit that i don't know if i had sit the phone in power off state long enough to see.
I upgraded to CM9 and got stuck with the problem.
I upgrade from CM9 to CM10.2 which was a drag because of the new partition layout.
Finally got it working with the same problem.
One difference: After shutdown the screen is blank and no "empty bat symbol" is shown.
If i connect the charger, the empty bat is shown flashing, going away, starts charging. Boots o.k. if done with charger.

A reboot alsways works if done immediately after shutdown!

State now:
I can make phone calls and everything after this until battery is low. I can charge in ON state and continue forever.
But every time i shutdown the phone and let it sit for some minutes it has the "inside empty bat situation" which will allow to boot
but does not recognize the SIM card.

I am really stuck on that.
My second i9000 came prerooted and ran on CM11 nightly which i downgraded to CM10.2 stable for productive use.
This is phone is fine with the battery from my problem child.

Any advice?

Thanks in advance,
6th May 2014, 01:04 PM |#2  
pryerlee's Avatar
Senior Member
Flag Bristol
Thanks Meter: 136
found this thread, not sure if it'll help
The Following User Says Thank You to pryerlee For This Useful Post: [ View ] Gift pryerlee Ad-Free
6th May 2014, 02:50 PM |#3  
OP Senior Member
Flag Siegen / Northern Rhine / Germany
Thanks Meter: 80
Nearly, but not exactly
Originally Posted by pryerlee

found this thread, not sure if it'll help

In between time i went back to 10.2 stable without gaaps. Nothing much changed...

Thanks alot for the quick response.
Nearly the same case here. Maybe the solutiion is posted in #31. Charging and draining to empty or so.

As said if i connect a charger the device boots, i can enter my SIM Pin and everything is fine.
If it is booted up i remove the charger, battery still over 80%. Everything works.
I shutdown, wait for a minute, power on.

Now wait, after the last clean wipe and install: It does not bootloop to battery empty. It boots up to the lock screen but without asking for the SIM Pin.
If i do nothing the phone keeps booting after a short while.
If i unlock the screen i can use the phone, including WLAN etc..but cannot make a call because baseband is empty.

Connecting the charger or usb in that case immediately locks the screen and asks for SIM Pin. Everything is fine...

6th May 2014, 06:06 PM |#4  
tetakpatak's Avatar
Senior Member
Flag Lucerne
Thanks Meter: 2,321
So is it an original Samsung battery or 3rd party? And it works perfectly fine in another i9000?

tetakpatalked from the legendary i9000
The Following User Says Thank You to tetakpatak For This Useful Post: [ View ] Gift tetakpatak Ad-Free
6th May 2014, 07:22 PM |#5  
OP Senior Member
Flag Siegen / Northern Rhine / Germany
Thanks Meter: 80
Originally Posted by tetakpatak

So is it an original Samsung battery or 3rd party? And it works perfectly fine in another i9000?

tetakpatalked from the legendary i9000

Yes, both batteries are Samsung. Old, though.

Well, during the day, after some more testing i can reproduce as follows:

Stock firmware either flashed with Heimdall or ODIN result in no problems at power-up.
Rooting no problem

CM works fine with CM 9.1 stable. No more empty battery sign and every boot SIM Pin is asked.

Going from CM9.1 to CM10.2 stable results into trouble. Something happens on repartitioning.
The phone boots several times .

After that, reboot system, the system starts but forgets to aks about SIM instead giving me the message
to read the manual on how to insert a SIM

I am just going to give it a shot again flashing stock to CM11 M6 built in one big leap.

Wait: It just boots into the new system.
Wow: It is asking for a SIM Pin. I give it and the rest of the primary setup is localized to German.
What is this? Do i dare to reboot after the ROM has settled? I guess i must...

This time something is different. The whole process from going stock to CM11 was done without charger applied.
It works flawlessly.
Hold your breath: I am going into shutdown.
Will a nandroid backup BEFORE next reboot.
6th May 2014, 08:22 PM |#6  
OP Senior Member
Flag Siegen / Northern Rhine / Germany
Thanks Meter: 80
SOLVED: Battery empty loop etc.
Dear readers: My issue has been solved.

To sum it up:

The flashing battery symbol has not necessarily something to do with the battery state.
If you notice that your charge is good either when connecting a charger and check the bat symbol or if the system is up than it
is not the cause of trouble.

Wiping batteriestats files is senseless. I see them on adb or on the file browser. They are always made new on time
a charger is disconnected. Maybe if one wants to calibrate the battery notifier it makes sense.
Not for this problem.

If the battery is charged and you see some kind of battery bootloop then it really is a bootloop.
The only remedy is to go back to stock and see if it is there, too.
IF it is there, then most probably there is something worng in the hardware, i guess.
So clean your battery poles with a fine grain of sandpaper (carefully!!!) or use a sort rubber we use in school to erase
uneraseable ink (do not know the word for "Tusche", sorry).
Clean the usb port with pressurized air used for cameras. Apply a small (!) amount of TESLANOL or Tuner spray or something else
for gold contacts.
Do this also for the contacts of the SIM and battery inside the case. Use Q-Tipps to apply and dry thoroughly.
Replace your battery if nothing helps.
On stock firmware no battery bootloops ever occur, i guess otherwise cellphones would not sell.

After going back to stock root your phone as usual.
You should confirm that one of the first stable CM or other mods reported to work fine work fine for you, too.
Go back to stock again and try large leaps through your ROMs.
I guess this is the way to go, finally.

In my case coming from CM 9.1 to 10.2 did something. I noticed the phone boot several times during flashing, due to repartitioning always
coming back without fault but in the end not fully functioning.

So my solution, after the battery bootloop went away which i tend to say is the result of charging and cleaning and going back
to stock WITH SIM and testing is:
Make huge leaps. It has to work or dump it.

If anything new occurs i will post in this reply.

Hope someone else can find valuable information in this thread.

Make yourself familiar with Heimdall. I found it to be much easier to use than Odin. But it depends on if you find the proper files to flash...

Best reagrds,
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes