Remove All Ads from XDA
Honor 9 Lite

S5 and SanDisk 64GB UHS-1 problems w/ camera

34 posts
Thanks Meter: 1
By alex_tytn, Member on 12th April 2014, 09:29 PM
Post Reply Email Thread
24th April 2014, 11:46 PM |#11  
Senior Member
Thanks Meter: 20
Im using the samsung evo 64gb micro sd card and so far no problems. Its been in the phone from day of release so maybe have a look at purchasing this card.

Sent from my SM-G900I using Tapatalk
25th April 2014, 11:24 PM |#12  
fastyan's Avatar
Thanks Meter: 6
I've had a similar problem, it started in my S4 with the 64gb SanDisk but I thought that the camera had gone faulty! Upgraded this week to S5 and put the sd card in it and all the pictures I took were OK for a minute then went corrupt? Also noticed that I couldn't put apps on the sd so process of elimination brought me to the card. Turns out it had gone faulty but had a second one in my gopro so put it in the phone and all is working perfectly but the other card is dead and can't even format it. Not sure if this helps or similar to your experience but thought I'd share

Sent from my SM-G900F using XDA Premium 4 mobile app
6th May 2014, 09:05 PM |#13  
OP Member
Thanks Meter: 1
Originally Posted by chimas16

Will this work ok?

I tried the Ultra and not Ultra-Plus. The Ultra worked for most things for me but not high speed cam/camera functions.

If you tried it please let me know.

From this point on I buy the Extreme Plus and never looked back.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes