Remove All Ads from XDA

Uninstalling major issues

3 posts
Thanks Meter: 0
By emilik, Junior Member on 6th May 2014, 06:55 PM
Post Reply Email Thread
Here's the deal, my moto G (XT1032) WAS working perfectly when Motorola was Google owned. After the first non Google update it started showing some problems. It is currently running on Android 4.4.2 and system version 174.44.1with NO hardware or software mods. The major issue now is that I can't uninstall ANY app, after I hit uninstall in the confirm window the phone reboots every single time, no matter what app. In addition to this, the same thing happens when you try to clear any apps data, also, you can't access the security settings as the settings app crashes every time you try to access security settings, and lastly, sometimes it reboots the phone says that it's optimizing one app of one, it freezes, crashes and reboots again until it is able to start.

THE MAIN ISSUE IS UNINSTALLING, and I have already heard that resetting to factory doesn't work.

Also trying to uninstall from the app launcher, play store or settings gives the same results.
7th May 2014, 06:03 PM |#2  
OP Junior Member
Thanks Meter: 0
After some fighting with my phone I came up with a solution.

1. Since the phone said that it was optimizing one app always, I assumed the problem was a single app. Then I deduced that app was Floatifications because it messed up with the phone security settings (for the notifications access) and was the most mod-heavy app I has installed lately. So I tried to uninstall it via ADB.
1.1 I had a second issue that the phone didn't recognized that it was connected to a computer. To circumvent this I booted into fastboot menu and I selected the BP tools option. When the phone booted up again with the service app activated it recognized the USB connection to the computer and turned on debugging mode.
2. I tried different commands to uninstall it via ADB, the one that worked was: adb shell pm uninstall -k <package name>
2.1 In this case of floatifications the whole command is 'adb shell pm uninstall -k robj.floating.notifications'
3. After a reboot everything was working normally. Including the USB connection.

For a final remark, I came up with this whole process by trial and error so maybe there is an easier way of doing all this stuff. I also uninstalled in the same process the lockscreen app "Cover" that also requested access to notifications but I don't think that app was the problem since the phone said it was optimizing one app and it isn't as muddy as Floatifications.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes