Remove All Ads from XDA

[Q] S-ON, but "Secure_flag" = 1350856192

253 posts
Thanks Meter: 89
By Lekerstein, Senior Member on 8th May 2014, 01:38 AM
Post Reply Email Thread
Hey all,

Here's my story. I hope someone out there can help. I've tried just about everything and can't figure this out.

I have an AT&T HTC One m7. A while back, I was S-OFF, unlocked, rooted, and happily running ARHD. Then, a few months back, my S-OFF flag randomly became S-ON, and that's where my problems began. I think it may have tripped back to S-ON while upgrading firmware (perhaps I accidentally flashed a signed firmware... I don't know). I originally S-OFF'd with revone, but my HBOOT was 1.56 when the S-ON tripped back on. I tried rumrunner and firewater incessantly, until at one point firewater did say I was S-OFF... but I wasn't actually S-OFF. Don't ask me how, but somehow I also managed to change my cid from 11111111 to HTC__001. I now cannot change it to CWS_001 as required for AT&T.

I've tried various combinations of roms and such to get S-OFF, but nothing is working. Tonight I just went back to stock using the 4.19 AT&T ("Cingular") RUU and having a relocked bootloader. That is my current setup. (see my "fastboot getvar all" results below)

Now what is really interesting is that just last night I realized that when I run "fastboot oem readsecureflag", I get the following result:

fastboot oem readsecureflag
(bootloader) secure_flag: 1350856192
OKAY [  0.001s]
finished. total time: 0.001s
After flashing the RUU just now, I tried running "fastboot oem writesecureflag 3" but got the following error:

fastboot oem writesecureflag 3
(bootloader) This project does not support SD card
OKAY [  0.001s]
finished. total time: 0.001s
In case it hasn't been clear so far, my goal is to return back to how I was originally set up: S-OFF, with unlocked bootloader, rooter, and running ARHD with the latest firmware. Although my phone functions as is, it just doesn't feel right knowing that something in the backbone of the phone is messed up.

By the way, running rumrunner doesn't work, and running firewater now (even with all of the requirements met) just gives me the error "there isn't a helluva lot to do here" - meaning firewater still thinks it managed to get me S-OFF, probably due to my strange secure flag number.

Any help would be appreciated!!!!

Here is my getvar results:

fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.56.0000
(bootloader) version-baseband: 4T.24.3218.09
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 4.20.502.1
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: ___
(bootloader) imei: ___
(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0712000
(bootloader) cidnum: HTC__001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4076mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-c6bbb6d4
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.049s
8th May 2014, 04:51 AM |#2  
Lekerstein's Avatar
OP Senior Member
Thanks Meter: 89
@beaups hooked me up with a fix over at #firewater on the IRC after remoting into my desktop. Turns out my mmcblk0p3 (pg1fs) partition was f***ed according to him, lol. I honestly have no clue how it happened. Anyway, I'm back in business! If you have a similar error, you probably have a corrupted partition and you are lucky you aren't perma bricked.
Post Reply Subscribe to Thread

firewater, s-on, secureflag

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes