Remove All Ads from XDA

[Q] Questions about a failed custom rom flash.

2 posts
Thanks Meter: 0
By kinasaw, Junior Member on 10th May 2014, 02:12 PM
Post Reply Email Thread
This is the first time I tried to install a custom rom. Please be gentle.

Device: Huawei Y300 (Bootloader unlocked and rooted)
TWRP Version:
Custom rom: (found here)

I mindlessly tried to flash cyanogenmod 11 (kitkat) on my Huawei Y300. Here was the last steps I did:
  1. copied rom and gapps zip files on phone root
  2. restarted phone in fastboot mode
  3. on ADB, ran
    fastboot flash boot path\to\boot.img
    (everything seem to be working fine)
  4. ran
    fastboot reboot
    (phone rebooted in TWRP)
  5. Tried to install rom file (installation failed)

From what I read, the version of my twrp is not compatible with kitkat? Now i believe I bricked my phone because I forgot to create a backup of the stock rom.

Is the stock rom still somehow there, hiding in my phone memory?
Is it possible to "undo"
fastboot flash boot path\to\boot.img
so that the "original" boot.img is used by my phone when I try to reboot it?

I am currently downloading Android SDK with a plan to upgrade my twrp for kitkat compatibility. I hope this will let me install cyanogenmod kitkat on my huawei. But I am not sure if I will succeed. If I still fail, can you guys tell me what other options I have to save my phone?


Edit: problem solved.
I learned how to properly flash/upgrade twrp via fastboot.. Retried installing rom with twrp 2.7 and it was successful.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes