Remove All Ads from XDA
Honor View 10

[Q] phone locked up, now wont boot cant get into recovery

20 posts
Thanks Meter: 1
By parakalien, Junior Member on 10th May 2014, 01:56 PM
Post Reply Email Thread
I've had my GS3 for around 2 years. Have run just about every AOSP ROM out there. I've been using slimkat without any issues. Yesterday my phone locked up while sending a text message and turned itself off.

Now it's completely bricked and I cant get into recovery, download mode, nothing.

Steps I've tried,
I've taken the battery out,
let it charge overnight,
tried plugged in and unplugged,
removed the SIM,
removed the micro SD card.

When I insert the battery I feel the vibration and see SAMSUNG flash. but nothing after that and no button presses will do anything.

Do I have any options or is it time for a new phone?
10th May 2014, 03:48 PM |#2  
audit13's Avatar
Recognized Contributor
Flag Toronto
Thanks Meter: 4,757
Do you have access to a USB jib in order to try and get into download mode? Have you looked at the de-bricking thread?
Post Reply Subscribe to Thread

brick bricked full, no recovery

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes