Remove All Ads from XDA

Unable to install drivers Help

65 posts
Thanks Meter: 1
By drakemiller40, Member on 12th May 2014, 12:03 AM
Post Reply Email Thread
I hope I posted this in the right subsection.

I used to be able to connect my s3 to my computer just fine. Now When I try to connect it, it randomly connects and then disconnects after a few seconds going back and forth like that. My computer doesn't have enough time to install the drivers for it since it disconnects on its own like that.

This is not my computers problem since it wont connect to my other computers. I even tried reinstalling the os on my pc for new set of drivers, but no luck.

Im sure it has something to do with my phone. My phone is rooted, so if any fixes include being rooted, Im good with that.

I tried changing from mtp to ptp connections, removing the battery, trying different usb ports and cables.Tried with usb debugging on and off too.

Im at my wits end here. please help!
12th May 2014, 01:16 AM |#2  
mrhaley30705's Avatar
Recognized Contributor
Flag North Georgia
Thanks Meter: 2,458
Donate to Me
Your usb port may be going bad. Check the port for any built up lint or other crap. Also check the pins, make sure they are all there and straight.
12th May 2014, 02:21 AM |#3  
drakemiller40's Avatar
OP Member
Thanks Meter: 1
I tried another USB cable and it worked

Sent from my SGH-I747M using XDA Premium 4 mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes