Remove All Ads from XDA

Rooting problem

2 posts
Thanks Meter: 0
By razzera, Junior Member on 11th May 2014, 10:38 PM
Post Reply Email Thread
I tried using windroid but i get "Device: not found" when my phone is plugged into the USB cable, i have HTC sync installed and it fins my phone, USB debugging is also enabled but still "Device: not found", why?!


I have a HTC one X(from Sweden) with Android 4.2.2 installed on it and i want to root it to upgrade to 4.4. I downloaded "OneXRootOneClick" but when i run the file to root as administrator in windows 7 i get "adb is not recognized as an internal or external command "

i then got the newest Android SDK and unpacked it @ > C:\temp\adt-bundle-windows-x86_64-20140321\adt-bundle-windows-x86_64-20140321\sdk\platform-tools

i then ran the following in CMD

set ANDROID_PLATFORM_TOOLS="C:\temp\adt-bundle-windows-x86_64-20140321\adt-bundle-windows-x86_64-20140321\sdk\platform-tools"

set ANDROID_TOOLS="C:\temp\adt-bundle-windows-x86_64-20140321\adt-bundle-windows-x86_64-20140321\sdk\tools"


but when i run the file in OneXRootOneClick again i get the very same thing once more, do anyone know why or how i could another way root my android(possibly without a reset)?
13th May 2014, 12:38 PM |#2  
OP Junior Member
Thanks Meter: 0
noone got any answer to this ? :/
13th May 2014, 02:37 PM |#3  
Mr Hofs's Avatar
Senior Member
Thanks Meter: 13,055
Open a command window inside the platform tools folders and place the phone in the bootloader, you should see fastboot USB in red text. Type this in the command window :

Fastboot devices

Tell me what happens.

And don't use a tool, let's do this the old fashioned way with straight commands.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes