Remove All Ads from XDA
Honor View 10

[Q] I messed up my new kindle hdx7

186 posts
Thanks Meter: 23
By AndroidMilos, Senior Member on 12th May 2014, 12:47 PM
Post Reply Email Thread
ug.I am visiting serbia now. My kindle is about 20 days old. I rooted it, safestrapped etc. Now I like the Kindle so much that I want to upgrade to the 64gb version. So I decided to unroot it without a pc, did a factory wipe which even deleted my stock backup so no OS available to restore. tried to power up and got as far as language choice then keeps going back to same page. So I tried a power down up and it just stays on same screen after I get thru the twrp screen. I dont have a pc available here. I want to at least rid this device of any rooting/twrp/safestrap stuff before I send back to Amazon
Any advice on this?

Fixed! As a last resort, I held the power key for a whole minute while kindle appeared to be resetting
A number of times with my finger stayed on the power button. It then powered up correctly and now runs like
A charm. So for now I am wondering if I really should pursue getting the 64 Gb version.
Hopefully this simple fix will help others.
13th May 2014, 04:15 PM |#2  
Junior Member
Thanks Meter: 0
Angry as i know you´re hdx is bricked
you show grey kindle logo? you are bricked your device and since know we have not solution
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes