Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Hi Guys,

Need your help on this. I have search everywhere and couldn't find any help. Anyhow, below is the story of my Galaxy S3 SGH-I747M Telus Canada.

It was stuck at "Galaxy S3" boot screen, not matter how many times I restart it by removing the batter. Funny thing I noticed was that, the phone will not enter "Recovery Boot", when I press the Vol+Home Button+Power it will say "Recovery boot on top left but it will just go back to "Galaxy S3" boot logo and sits there. It can only go to download mode and that's it. I tried Samsung kies to restore, it seem it will work but it will come up with a message "This device can not be updated"

So I decided to use Odin instead to re-flash 4.3 firmware. The first attempt failed it didn't even started loading the firmware in it, it just failed. The second attempt, I thought it would work, it said writing nand and when it got to part where odin said "BOOT" that's when it failed. Got a message on my phone "Odin Flash Failed". I thought, oh crap, that's can't be good. so I finally decided to power off my phone. The sad part now is, it wouldn't even boot up and it wouldn't even go to download mode. I tried USB jig and also GPG cable and no luck will not go to download mode. The phone is just completely blank screen..

However, I'm still having a little bit of hope. When I connect to my computer, it recognizes it, I hear the sound and detecting drivers, but Odin doesn't see my phone anymore. Anyhow, anyone come across this issue? Please help, I greatly appreciate it. Thank you.
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes