Remove All Ads from XDA
Honor View 10

Dead or not? Questions about my E975

12 posts
Thanks Meter: 6
By ThatAndroidGuy91, Junior Member on 15th May 2014, 09:17 PM
Post Reply Email Thread
Hi everybody. I managed to soft brick my brand new Optimus G by uncarefully removing some unneeded Google apps. After that phone did not boot and all I see was LG logo in booting screen and "Security check failed" message (or something like that). After that I tried to solve my problem by following this guide. I managed to flash the bin and phone booted correctly after 67%. But after that there have been some problems. I managed to open fastboot-menu (I think) once and after that there has been no luck. There seems to be some problem with charging as phone is not showing any signs when put to charger and nothing happens when I try to open fast boot or download mode.

So, is my phone already dead or do I still have hope? I read somewhere that these charging issues could be solved by removing battery but I dont have Torx 5 to try it yet.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes