Remove All Ads from XDA

[STUCK] I've no idea what's happening

25 posts
Thanks Meter: 2
By welie, Junior Member on 17th May 2014, 02:20 PM
Post Reply Email Thread
I've HTC One m7 which I converted to GPe about a month ago. This is the tutorial I followed:
I needed to get my phone to a service station so that I can get my capacitive buttons repaired, so I followed the stock conversion method in the above thread.

Here's what I did, step by step

1. I was on GPe, rooted, TWRP recovery, S-OFF and unlocked bootloader
2. I flashed Hboot 1.44 mentioned in the above thread.
3. Flashed the for my model ( CID was supercid when this was done)
4. Restored my original cid
5. I again installed TWRP recovery to run guru's bootloader reset, by which I locked my device again.
6. Here's where the problems begin. My USB 3.0 port doesn't detect phone in fastboot ( I'm on Ubuntu 14.04)
7. Here's the output of two consecutive fastboot getvar all command on USB 2.0
fastboot getvar all
getvar:all FAILED (status malformed (0 bytes))
finished. total time: 1.001s
fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.44.0000
(bootloader) version-baseband: 4A.14.3250.13
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 1.29.707.4
(bootloader) version-misc: PVT SHIP S-OFF
(bootloader) serialno: FAxx
(bootloader) imei: xx
(bootloader) meid: 00000000000000
(bootloader) product: m7_u
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0711000
(bootloader) cidnum: HTC__038
(bootloader) battery-status: good
(bootloader) battery-voltage: 3871mV
(bootloader) partition-layout: Generic
(bootloader) security: off
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
getvar:all FAILED (status read failed (Value too large for defined data type))
finished. total time: 8.031s
It is also really slow, which makes me worried that if I flash ruu again, it will stop midway

8. I downloaded the official OTA update, but when I install it, it leads me to TWRP recovery where it does nothing.

Now what should I do? I need to go to complete stock status. Will it be OK if I flash ruu again, or will I run into some trouble in case it stops midway?

EDIT: Couple of things I forgot to mention
1. I have a full stock nandroid(except for the recovery) for 4.4.2 which I took before converting to GPe
2. I also searched for stock recoveries, but I can't find one for 1.29.707 , if I get one maybe it can resolve some issues by installing the OTA.
17th May 2014, 03:24 PM |#2  
OP Junior Member
Thanks Meter: 2
This is what I've done so far

1. Downloaded 4.20.707.7 stock rom reset from
2. Tried fastboot getvar all
It seems that even my firmware is still 1.29.707.4
3. In the same thread, firmware was also available. Here are my output of flashing it

xxxl@xxx:/mnt/Storage/HTC One/Going Back To Stock/4.2.2 By Yatin xda/4.2.2$ fastboot oem rebootRUU
FAILED (status malformed (0 bytes))
finished. total time: 1.001s
xxx@xxx:/mnt/Storage/HTC One/Going Back To Stock/4.2.2 By Yatin xda/4.2.2$
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes