Remove All Ads from XDA

[Q] Nav buttons servicing, need idea

387 posts
Thanks Meter: 194
By Closed Force, Senior Member on 18th May 2014, 12:54 PM
Post Reply Email Thread
Hey guys, I desperately need your help. Recently my soft/navigation/nav buttons began to malfunction, and when they almost stop responding, I decided to replace them. Bought new ribbon assembly (cable, home button, nav buttons, microphone, charger port, 3.5mm port), replaced it easy. Again everything worked except the nav buttons (neither their led). Tried disassembling and assembling few more times, but no change. Put back my old part, and could make it work and shine in some positions. Decided that part that I bought is broken, and bought NEW one from other reseller. SAME problem!
Have no idea, should i buy third one? Or maybe it's motherboard related (which I hardly believe since original part is occasionally working)? Or firmware (should i try with some other regions)? Maybe there is some incompatibility with this parts that I buy (there is some "rev" number on them that is not the same as on my old part). Maybe something needs to be calibrated (heard of that *#*#2663#*#* code?!). Please help me, thank you.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes