Remove All Ads from XDA
Honor View 10

S4 i9506 charging issues, won't charge more than 20%

4 posts
Thanks Meter: 0
By A.Mavromati, Junior Member on 21st May 2014, 01:24 PM
Post Reply Email Thread
Hey guys, got a problem with my S4 i9506, yesterday all of the sudden its telling me that the usb cable is pluged in (message when u plug the usb), but I just surf the web without any cable attached! afterwards it started to get a little hot on the back, and later the evening, when the battery was drained, I pluged the charger and it would NOT charge! it did see the plug, the battery icon changed, but the battery were still going down! I tried another S4 battery, same thing - so its the phone. I googled the issue, cleaned the USB connections carefully, tried hard reset, tried charging from PC (the PC detects the phone, I can transfere files), so the USB port seems to be fine. the battery died comepletly, I tried do charge when its turned of, did't help, its just vibrating every second, without any display activity. I put it overnight charging, woke up this morning and it did acctually charge, but VERY slowly, and won't get higher than 20% charge.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes