Remove All Ads from XDA

The houdini folder

261 posts
Thanks Meter: 28
By numskull, Senior Member on 20th May 2014, 10:44 AM
Post Reply Email Thread
Right then this is a strange one, as the thread title implies i have a dodgy folder that has done a dissapearing act on me........ the strange bit is, it has reappeared.

This may or may not be related to the ta folder/drm keys, im not a developer, i honestly have no idea.

Anyway, i'll try and keep it as brief as possble. I've had my z2 for about a month, i unlocked the bootloader and rooted a couple of nights ago, didn't do it sooner as didnt want to lose drm keys. All the time i had locked bootloader i was searching for a way to try and get the ta/drm onto my laptop from my phone, with no luck lol.

While doing this i came to the (probably wrong) conclusion the the ta/drm file we need to back up is called 'mmcblk0p1, and can be found on root of phone in, dev- block- platform- msm_sdcc.1- by name.... scroll down, its the one called TA, 3 things made me believe this was it

1... Thats where the guide for backing up ta on z1 leads you

2... Its where all the ta backup apps go

3.... Its called TA

I finally gave up and unlocked my bootloader and rooted as after almost a month i was more aware of what got affected, i should point out now that everytime i tried to get this file, when i clicked platforms there were 2 folders to choose from, msm_sdcc.1 and msm_sdcc.2, i had a look in the second folder and it appeared to have the same contents as the first one but there wasnt a 'by name' folder.

After unlocking the bootloader, i tried to get to it again....when i clicked platforms there was only msm_sdcc.1, i opened it, looked the same, went by name, scrolled down n there was the TA mmcblc0p1. I tried this because id read a few things saying that TA/DRM didnt get wiped on z1 after unlocking bl on android 4.4..... so i figured as the msm_sdcc.2 had vanished then that must be what we needed to back up.... makes sense right?

So anyway, went n did my other checks regarding bootloader unlocking and stuff functioning, then flashed recovery and rooted, now i dont know if it was the recovery, root or factory reset but something has made msm_sdcc.2 reappear on my phone and as if that aint strange enough, its 50/50 as to wether i can open the folder or phone freezes, and if i can open it and try to do anything with mmcblk0p1 my phone just dies.... well passes out, screen freezes and becomes unresponsive then goes blank, after a while it will reboot and everythings lagging, i have discovered the cause to be that upon trying to do anything with msm_sdcc.2 or mmcblk0p1 located inside, root explorer devours all my damn memory, i have approx 10 gig free beforehand and after its froze and rebooted i have 0 free memory and upon checking apps rootexplorer has 10gig of data

What the hell is this folder and why does it crash my phone??? Anyone have any thoughts on this??
Sorry for long post n poor grammer/punctuation
20th May 2014, 10:06 PM |#2  
OP Senior Member
Thanks Meter: 28
No one have any thoughts on this?

I was wondering, is it possible that the drm keys dont get wiped as such, they just cant be activated on an unlocked bootloader? I wonder this because my x reality clearly isnt making any difference (as expected on ul bl) but ive read some comments saying its working again if you relock the bootloader
The Following User Says Thank You to numskull For This Useful Post: [ View ] Gift numskull Ad-Free
21st May 2014, 12:11 AM |#3  
Envious_Data's Avatar
Senior Member
Thanks Meter: 2,295
Donate to Me
If your asking to make Fake DRM keys or tricking the system into thinking they are there then that is not posible

Sent from my D6503 from XDA Premium 4 mobile app
21st May 2014, 07:20 PM |#4  
OP Senior Member
Thanks Meter: 28
Originally Posted by Envious_Data

If your asking to make Fake DRM keys or tricking the system into thinking they are there then that is not posible

Sent from my D6503 from XDA Premium 4 mobile app

How on earth did you come to that conclusion????

Read what i wrote again, i had a folder deleted when i unlocked the bootloader, then later (not sure when, it would be from either flashing doomlords advanced stock kernel, rooting or flashing doomlord v5 kernel) said folder reappeared, but i cant do anything with file inside, trying to copy them to my computer, move them inside the phone or even just just trying to open it to view, crashes my phone..... i want to know what this folder is/contains.

Because of where it is located and that it got wiped when i unlocked the bootloader, im thinking maybe its got something to do with the drm keys, then i got to thinking maybe it actually is the drm keys and they need to verify that the bootloader is locked before working (i suppose similar to an app doing a license check), this could possibly explain how some people who have unlocked and rooted claim to have xreality working again if they relock bootloader

Hopefully that was a bit clearer
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes