Remove All Ads from XDA

[Q] Troubleshooting boot problems

193 posts
Thanks Meter: 166
By dmroeder, Senior Member on 21st May 2014, 08:49 PM
Post Reply Email Thread
Disclaimer: This is my first time trying to compile a ROM.

I was hoping that I could get a little advice on troubleshooting my build that won't boot. I'm building Omni for my Motorola Atrix 2 and I have gotten it to build successfully and it installs. It will never completely boot, it hangs at the boot animation indefinitely. I suppose there are probably many things that cause this but I'm lost on where to start. I've looked through a lot of peoples local_manifests to see what repos they were adding/removing and it always ends up the same for me, stuck on the boot animation. So here's a little information about my build:

Device: Motorola Atrix 2 (edison)
PC Mint 15 KDE 64 bit with 8GB or RAM and ~1TB of free space
Devices/kernel sources: (Tried CM11 and a dev suggested trying slim4.4)

My current local manifest:

<?xml version="1.0" encoding="UTF-8"?>

<!-- REMOVALS -->
<remove-project name="android_hardware_ti_omap4xxx" />
<remove-project name="platform/hardware/ti/wlan" />
<remove-project name="platform/hardware/ti/wpan" />
<remove-project name="android_hardware_libhardware_legacy" />
<remove-project name="android_external_wpa_supplicant_8" />

<!-- DEVICE -->
<project name="MO4/android_device_motorola_edison" path="device/motorola/edison" remote="github" revision="slim4.4" />
<project name="MO4/android_device_motorola_maserati" path="device/motorola/maserati" remote="github" revision="slim4.4" />
<project name="MO4/android_device_motorola_omap4-common" path="device/motorola/omap4-common" remote="github" revision="slim4.4" />
<project name="MO4/android_device_motorola_spyder" path="device/motorola/spyder" remote="github" revision="slim4.4" />
<project name="MO4/android_device_motorola_targa" path="device/motorola/targa" remote="github" revision="slim4.4" />
<project name="MO4/android_device_motorola_umts_spyder" path="device/motorola/umts_spyder" remote="github" revision="slim4.4" />

<!-- KERNEL -->
<project name="MO4/android_kernel_motorola_omap4-common" path="kernel/motorola/omap4-common" remote="github" revision="cm-11.0" />

<!-- VENDOR -->
<project name="TheMuppets/proprietary_vendor_motorola" path="vendor/motorola" remote="github" revision="cm-11.0" />

<!-- EXTRAS -->
<project name="CyanogenMod/android_external_wpa_supplicant_8" path="external/wpa_supplicant_8" remote="github" revision="cm-11.0" />
<project name="CyanogenMod/android_external_wpa_supplicant_8_ti" path="external/wpa_supplicant_8_ti" remote="github" revision="cm-11.0" />
<project name="CyanogenMod/android_hardware_ti_omap4xxx" path="hardware/ti/omap4xxx" remote="github" revision="cm-11.0" />
<project name="CyanogenMod/android_hardware_ti_wlan" path="hardware/ti/wlan" remote="github" revision="cm-11.0" />
<project name="CyanogenMod/android_hardware_ti_wpan" path="hardware/ti/wpan" remote="github" revision="cm-11.0" />
<project name="CyanogenMod/android_prebuilt" path="prebuilt" remote="github" revision="cm-11.0" />
<project name="alteredlikeness/slim_hardware_libhardware_legacy" path="hardware/libhardware_legacy" remote="github" revision="kk4.4-mo4" />

There are a couple of things that I wasn't sure of with my build. First, my phone uses BootMenu Manager for recovery, not TWRP. The source I grabbed for my device are from ROM's that also use BMM. Could this be related to it not fully booting? Second is the omni.dependency file in my device directory. It appears that this might be used instead of a local manifest for devices that are officially supported by Omni? Since mine is not, I used the local manifest to get my device/kernel sources so my omni.dependency file is essentially empty.

After a couple of weeks of trying to get this to boot, I decided to switch to CM11 to see if I could build anything and I got that to boot. Granted this has already been done for my phone so all the leg work with the sources was pretty much done. I just wanted to see if I got the same result with another ROM.

I tried to get ADB working to see if I could get a logcat or something but since I cannot get it to boot, I cannot authorize my phone so it always says "unauthorized" when I try to connect while it's stuck. I don't think it produces a last_kmsg since the kernel doesn't crash. I'm not sure where to go from here other than give up. I'd hate to do that though!

Any advice?
Post Reply Subscribe to Thread

edison, omni, stuck at bootanimation

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes