Remove All Ads from XDA

[Q] 2 GPE HTC Ones. One with no OS, other fails oem unlock, Both have a Sticky S-ON

5 posts
Thanks Meter: 0
Post Reply Email Thread
So this saga started with me in a hurry I was trying to return a phone back to stock (had TWRP and wasn't accepting OTAs it was a favor to a friend who was returning it for a camera problem repair). There wasn't enough space to flash the ROM. I had TWRP 2.6 I chose to wipe. In a flurry of stupid activity I chose to wipe the system along with the cache and dalvik cache clearing anything that might have been in my way and, Boom! no OS. I new what I did. I shouldn't have let my 15 minute time crunch screw me up.

Unfortunately the device (GPE edition, truly) has S-ON and has an hboot of 1.54. So I see no way to achieve S-Off and I've been failing on any attempt to flash an RUU. tried this both with TWRP recovery and with stock recovery installed. When I had stock recovery my fail was:

FAILED (remote: 24 parsing android-info fail)

I feel like I've tried every permutation of GPE ROM.
My FUBAR HTC One has a CID GOOGL001 and MID PN0712000. getvar all reports:

(bootloader) version-baseband: 4A.18.3263.15
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0712000
(bootloader) cidnum: GOOGL001

The bootloader locks and unlocks at will via oem unlock/lock.

I had this bright Idea that I could do a NANDroid backup if I installed the TWRP on another GPE HTC One M7 I had access to, but it has 4.4.2 and in bootloader,

fastboot oem unlock
gave me something many people have been dealing with, the Google Edition with the famously unlockable bootloader fails on unlock:

(bootloader) [PG_ERROR] htc_pg_part_traverse(839):
(bootloader) invalid traverse range
(bootloader) [PG_ERROR] htc_pg_part_read(1029):
(bootloader) htc_pg_part_traverse failed
(bootloader) [DISPLAY_ERR] sp_custom partition: unlock_disp_buf.img_buf r
(bootloader) ead error!
(bootloader) [DISPLAY_ERR] Can not load custom splash!
(bootloader) Loading custom splash failed!

I followed each thread I could find on this subject and they all seem to die out with comments that there is no solution to this locked bootloader issue at the moment, so I guess no TWRP recovery? I don't care too much about this last issue I just wanted to recover my (well my friend's, who might be reconsidering that status) soft bricked M7. This has been such a fiasco of ID-10T errors! I'm replacing my friend's phone so now I have nothing to loose. I will attack this brick with anything radical that makes sense.

I've been a fairly quiet person on these forums since the first Android phone (G1, still have it, don't use it). I'm on a GPE M8 these days, myself, I didn't give my M8 to my friend.

I greatly appreciate any information anyone has. Thank you.
23rd May 2014, 05:57 AM |#2  
Senior Member
Thanks Meter: 517
Donate to Me
Keep the bootloader unlocked and adb sideload a custom ROM using twrp
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes