Remove All Ads from XDA

[Q] Unable to flash stock firmware

6 posts
Thanks Meter: 0
By Exposure, Junior Member on 23rd May 2014, 09:47 PM
Post Reply Email Thread
I'm trying to flash a stock firmware on my new Z1 Compact to get rid of German operator branding (I'm in The Netherlands). This is my first Xperia device but I've flashed Android devices a bunch of times before.

I've checked a couple of guides, downloaded Sony PC Companion, the latest FlashTool and a x.681 Z1c firmware, since that would give me the opportunity to make sure OTA updates still works when the device updates itself to x.757. I've no interest in unlocking the bootloader or obtaining root, just yet.

First I installed just the flash-mode and Z1c drivers for FlashTool but after some more reading I installed all drivers in the driver pack. Also tried multiple firmware images from different sources. Whichever I use, the results is always the same: Processing of loader.sin finished with errors.
I've found some posts referencing this error for different devices, some answers suggesting to install the latest FlashTool and drivers, but there doesn't seem to be a definitive answer on what causes this error (and how to solve it).

I think I'm supposed to see a green led when the device is in flash mode. Instead I get a led that blinks red/green for a (fraction of) a second, and then turns off. FlashTool doesn't complain though and starts the flashing process. Most of the time it takes quite some time 'reading device information' but sometimes it proceeds immediately, the error about loader.sin is always the same though. The processHeader:995 error doesn't appear every time.

Any advice? Since I'm out of ideas...

23/026/2014 22:26:44 - INFO  - <- This level is successfully initialized
23/026/2014 22:26:44 - INFO  - Flashtool Version built on 19-04-2014 19:00:00
23/026/2014 22:26:44 - INFO  - Checking if changes have been made to devices folder.
23/026/2014 22:26:49 - INFO  - Pulling changes from github
23/026/2014 22:26:49 - INFO  - Devices sync finished.
23/026/2014 22:26:57 - INFO  - Device connected with USB debugging off
23/026/2014 22:26:57 - INFO  - For 2011 devices line, be sure you are not in MTP mode
23/026/2014 22:26:58 - INFO  - Selected Bundle for Sony Xperia Z1 Compact (D5503). FW release : 14.3.A.0.681. Customization : Commercial
23/026/2014 22:26:58 - INFO  - Preparing files for flashing
23/027/2014 22:27:21 - INFO  - Please connect your device into flashmode.
23/027/2014 22:27:31 - INFO  - Device disconnected
23/027/2014 22:27:50 - INFO  - Device connected in flash mode
23/027/2014 22:27:50 - INFO  - Opening device for R/W
23/027/2014 22:27:51 - INFO  - Reading device information
23/028/2014 22:28:49 - INFO  - Unable to read from phone after having opened it.
23/028/2014 22:28:49 - INFO  - trying to continue anyway
23/028/2014 22:28:49 - INFO  - Start Flashing
23/028/2014 22:28:49 - INFO  - Processing loader.sin
23/028/2014 22:28:49 - INFO  -     Checking header
23/028/2014 22:28:49 - ERROR - Processing of loader.sin finished with errors.
23/028/2014 22:28:49 - INFO  - Ending flash session
23/028/2014 22:28:49 - ERROR - Error in processHeader : 995 : The I/O operation has been aborted because of either a thread exit or an application request. 
23/028/2014 22:28:49 - ERROR - Error flashing. Aborted
23/028/2014 22:28:50 - INFO  - Device disconnected
23rd May 2014, 10:49 PM |#2  
zxz0O0's Avatar
Senior Member
Thanks Meter: 4,626
Donate to Me
What is your operating system? Have you tried deactivating anti virus or another computer?
23rd May 2014, 11:07 PM |#3  
OP Junior Member
Thanks Meter: 0
Good news, flashing in progress as I'm typing this

I was using a Windows7 VM (vmware). I've tried the Linux version of FlashTool instead and it's flashing now. Had my share of troubles with USB devices on VMs in the past but usually stuff just didn't work / wasn't detected properly by the VM. Since everything seemed to work and install fine with the Z1c, I didn't suspect VM issues but I should have known better...
Post Reply Subscribe to Thread

firmware, flashtool, stock

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes