Remove All Ads from XDA

[Q] Help i9500 S4 : internal SD card not mounted and vanished

242 posts
Thanks Meter: 15
By HyperEscape, Senior Member on 25th May 2014, 10:31 AM
Post Reply Email Thread

Will try to explain the situation to my best possible knowledge :

1. Was running Crash ROM 4.4.2 on Galaxy S4 i9500 , have got all the required apps installed and configured the way I wanted.
2. Running the stock kernel which comes with the Crash ROM installation.
3. Running Phillz touch recovery 6.3.xx
4. Have external micro sd card (16GB UHC SanDisk) . Crated 1st primary partition as FAT32 and 2nd primary as Ext3 for moving apps.
5. Did install Link2SD and correctly moved all apps linked to the 2nd external SD card partition.
6. Was able to connect a USB flash drive via female USB connector (host mode) and take titanium backup of all apps.
7. Everything mounted correctly and automatically, with correct permissions to read/write without me worrying or fixing any setting or changing anything.

Since I had everything in order, I thought of making a nandroid backup via Phillz recovery . The problem when I tried taking a nandroid baclup which presents custom backup option to either "/sdcard" or "/storage/sdcard1 (which i assume refers to external microSD card".

I tried taking a backup at both locations and was informed that I am short of space , the backup needed 4+GB whereas I had 2+GB on internal SD and 3+ GB on external microSD available.

So i thought to reboot and try making some space anywhere, thats when the nightmare started.

After reboot, now there was

1. A message for low space remaining
2. Google play store continually crashing and giving a "stopped" message.

I fixed the error no. 2 temporarily by uninstalling google play store (updates, cache and then the app itself).

However error no.1 persists, now when try running any app to see what and how much space is left in the internal and external SD cards, it seems that the internal SD card is not mounted somehow.

I have tried runnning ES explorer and it says no SD card found. Even though I can browse to the root partition. Then I tried Link2SD (which has an option of seeing storage info nicely) and I can that the bar for SD card is blank and all other places or mount points are mounted.

Even the apps residing on my external microSD 2nd partition are working fine, however I noticed that earlier the external microSD card, when seen from inside a booted and loaded ROM was mounted at the location " /storage/extSDcard , but now it is mounted at "/mnt/media_rw/extSDcard"

But my internal SD card is vanished, I cannot find any contents of the "internal SD" in any of the locations at /storage , /storage/emulated/legacy, /storage/emulated/0, /sdcard, /mnt/sdcard, /mnt/obb and possibly any other location I can think of.

I believe the mount points and logical links are different as seen by the phillz recovery (as there is no /storage/sdcard1 when seen from Es explorer) , and as seen when the ROM is fully booted and loaded, so when trying to take a nandroid backup via Phillz recovery, it might have messed up with the mount points and/or permissions.

I hate doing a complete re-flash of the ROM again and spending hours to get all the apps customized my desired way, with all widget settings.

I am not an expert or pro at android, hence I request your help to sort out the issue, and maybe send or guide me the default way the S4 handles mount points, so I can get back the SD card and also guide me how to make a the nandroid backup to avoid this fiasco again.

Thanks for reading.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes