Remove All Ads from XDA

[Q] htc one m7 "set_metadata_recursive" please help

9 posts
Thanks Meter: 1
By luckynesooo, Junior Member on 26th May 2014, 02:02 PM
Post Reply Email Thread
i get this in the recovery while flashing android revolution hd and i restored my phone back to the stock from the backup i did.
i tried flashing one_4.19.401.11_deodexed and the same problem showed up

>>> Setting permissions
set_metadata_recursive: some changes failed
E:Error in /data/media/0/
Installation aborted

i tried multiple times, i downloaded the files again but the same message i get at the end of the log in cwm every time

any help, please and thank you so much

I'm running stock htc rom sense 5.5 android version 4.3
software number 3.62.401.1 rooted with custom recovery s-on
26th May 2014, 03:15 PM |#2  
nkk71's Avatar
Recognized Developer / Recognized Contributor
Flag Beirut
Thanks Meter: 7,082
Donate to Me
Originally Posted by luckynesooo

set_metadata_recursive: some changes failed

next time please use the search function, this has been covered more than enough times, and all over the place

you're using an outdated recovery, get TWRP from:
(make sure MD5 is correct, that site does not play nice with download managers)

in bootloader/FASTBOOT USB:
fastboot flash recovery openrecovery-twrp-
fastboot erase cache
fastboot reboot-bootloader

C:\ADB3>adb version
Android Debug Bridge version 1.0.31

C:\ADB3>fastboot devices
HT34xxxxxxxx    fastboot <- you are in bootloader

C:\ADB3>fastboot flash recovery openrecovery-twrp-
target reported max download size of 1514139648 bytes
sending 'recovery' (9184 KB)...
OKAY [  1.209s]
writing 'recovery'...
OKAY [  1.144s]
finished. total time: 2.354s

C:\ADB3>fastboot erase cache
******** Did you mean to fastboot format this partition?
erasing 'cache'...
OKAY [  0.120s]
finished. total time: 0.120s

C:\ADB3>fastboot reboot-bootloader
rebooting into bootloader...
OKAY [  0.160s]
finished. total time: 0.160s
if the ROM is no longer on your phone:
-> enter RECOVERY

C:\ADB3>adb version
Android Debug Bridge version 1.0.31

C:\ADB3>adb devices
List of devices attached
HT34xxxxxxxx    recovery <- you are now in recovery

C:\ADB3>adb push /sdcard/
2990 KB/s (1172224138 bytes in 382.835s) <- yes, it took over 5 mins,
                                            without showing any progress

Just to double-check the file is not corrupt
C:\ADB3>adb shell md5sum /sdcard/
2eff0d37fec5789b946c43f7da2c13bf  /sdcard/
from the OP: Android Revolution HD 52.0 -- MD5 sum: 2EFF0D37FEC5789B946C43F7DA2C13BF -- ==> so all is good :)
-> in recovery, select "install" and install the ROM
The Following User Says Thank You to nkk71 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes