Remove All Ads from XDA

[Q] not charging

63 posts
Thanks Meter: 19
By sbuldur, Member on 25th May 2014, 10:57 PM
Post Reply Email Thread
today i used my phone underwater for a while. before getting into water i checked all plugs. when i came i tried to charge via wall charger but it failed.

then i saw that charger plug was deformed little but there is not any water.

phone fully discharged after a while and can not be opened.

can i solve my problem via magnetic charger ?

i flashed doom kernel, is it software or hardware problem ?

i need help cause i bought my phone from thailand and it is out of warranty.

26th May 2014, 01:50 AM |#2  
Account currently disabled
Flag Kepler-34b
Thanks Meter: 5,680
1. Try a different charger (USB)

Does it work? Great. Does it still not work? Now you know it's not the charger that's the problem.

2. Open the right flap (with the SIM and SD port) and see if the water indicator is still white. Is it white or pink?
26th May 2014, 09:29 AM |#3  
OP Member
Thanks Meter: 19
indicator is still white.

also charger works on other device.

when i connect the charger red light turns on for a while then i saw doom kernel picture, then an empty battery icon appears just for 2 seconds and phone closes again.
27th May 2014, 09:04 AM |#4  
OP Member
Thanks Meter: 19
At morning İ was able to charge my phone and flashed stock kernel with recovery.

I am getting magnetic charger today.i will change the deformed right flap and never gonna use usb port again
28th May 2014, 06:41 AM |#5  
Junior Member
Thanks Meter: 0
I was having a similar issue so I took it to Bell [carrier in Canada] and they said it was a defect so they gave me a brand new updated Ultra. Maybe try that route. But you will lose all your data
Post Reply Subscribe to Thread

ultra battery charge red led

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes