Remove All Ads from XDA

[Q] Flashing a recovery from fastboot NEVER works!

19 posts
Thanks Meter: 2
By Jaeryl, Junior Member on 29th May 2014, 03:06 AM
Post Reply Email Thread
Is it just me or is not possible to flash a recovery, like TWRP from fastboot? I've been reading a bunch of guides online and tried at least a dozen different ways to install a recovery from fastboot all to no avail.

That said, I CAN successfully flash a recovery from Hasoon's all in one toolkit and from a app like twrp/cwm/flashify after installing a rooted rom. So the fact that I can't get it to work from fastboot, yet it works perfectly fine with this pre-made program has been bugging the living **** out of me. I'll list the two processes I use below so please tell me either they are incorrect or perhaps it's just simply not possible to install TWRP or other recoveries from fastboot.

I have tried each of these processes with versions ranging from TWRP 2.5-2.7 and none of them will work, each time I flash them and attempt to access the recovery it will say in pink lettering above "entering recovery..." then it just reboots the phone, occasionally the teamwin loading screen will pop up but then it simply disappears and reboots.

Anyways here's the processes I've tried
1. in the cmd prompt I do 'fastboot flash recovery TWRP.img' then reboot the bootloader and go to the recovery.

2. in the cmd prompt I do 'fastboot flash recovery TWRP.img' then do 'fastboot erase cache' and restart the bootloader then attempt to enter recovery.

These are the two slightly different processes I've tried, each time it appears as though it's working in the cmd prompt but then when I go to start the recovery it just reboots the phone. Also incase you're wondering, I did rename each of the recoveries to TWRP all uppercase before attempting the flash them).

If you have any ideas please let me know, although this isn't too big of a deal this has been bugging me a lot!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes