Remove All Ads from XDA

What does 'dns robustness' mean on build 16664?

1 posts
Thanks Meter: 0
By Milo333milo, Junior Member on 4th May 2014, 05:46 PM
Post Reply Email Thread

So, since Chromecast updated to 16664 i have been unable to use it in conjunction with Unblock-Us VPN service. This is only the case when attempting to play through chromecast, all other devices work as expected. I have tried routing my primary AP router to Unblock-Us DNS servers and i have also set up a dd-wrt router as a repeater and applied all necessary measures to preroute chromecast dns requests or simply block its dns requests. None od this has worked unfortunately.

The build update for 16664 stated 'dns robustness' which i figure is why this has happened. Does anyone know what this mean? Perhaps, if we knew this info we could figure out a work around.
4th May 2014, 06:19 PM |#2  
hunnymonster's Avatar
Senior Member
Thanks Meter: 43
Usually robustness would mean some sort of protection for it... Like perhaps routing the DNS requests over some sort of secure tunnel/connection so they're invisible to any local DNS caching or rewriting... Someone with Wireshark should be able to see exactly what is (or isn't) happening quite easily though.
8th May 2014, 04:43 AM |#3  
Senior Member
Flag Toronto
Thanks Meter: 77
I know this won't be very helpful at all, but I got my Chromecast today and it works just fine with my unblock-us account. I have the unblock-us dns servers set in my router (using Tomato rather than dd-wrt) and I was able to switch regions seamlessly.

Sent from my HTC One_M8 using XDA Premium HD app
8th May 2014, 06:09 PM |#4  
Senior Member
Thanks Meter: 114
I checked this latest build to see if it is still necessary to block or redirect Google DNS lookups to use another DNS, and it is. No change there, at least from Canada (UK/Europe firmware may be different).
31st May 2014, 09:21 AM |#5  
Senior Member
Thanks Meter: 22
netflix was not working with build 16664, hulu plus is fine. i had to redirect google DNS to a non existent IP address to get netflix to work. now both are running fine. i'm using adfreetime DNS on my Linksys router.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes