Remove All Ads from XDA
Honor View 10

HTC One (m7) No Red light while Charging

25 posts
Thanks Meter: 0
By mad_bro, Junior Member on 26th May 2014, 05:12 AM
Post Reply Email Thread
Red light (led) is not working while charging. Green led works fine and light up when phone is fully charged but during charging process no red light. Tried factory reset, rebooting but no luck. Tried the service test function and red light did not work.
26th May 2014, 07:30 AM |#2  
davebugyi's Avatar
Senior Member
Flag Bratislava
Thanks Meter: 906
Donate to Me
You mean the AMBER light during charge?
Are you on custom ROM? Custom kernel? More info is needed?

Mine was very weak after update, I tried these commands and they fixed it:


chmod 0333 /sys/class/leds/amber/brightness; echo 0 > /sys/class/leds/amber/brightness - disables RED LED completely
chmod 0644 /sys/class/leds/amber/brightness - enables it

Enter the commands in a terminal (terminal emulator app), with SU (ROOT).


You're basically changing permissions so the system cannot modify the brightness property of the LEDs. You are then setting the brightness to 0. Until you change the permissions back to 644, your LEDs will be off. No charging light, no LED notification.

1st June 2014, 01:45 AM |#3  
Thanks Meter: 5
The commands worked for me on arhd 71.
Many thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes