Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Okay so I've been looking for a LONG TIME trying to find a solution to this problem, but have yet to find one, so if this thread is a duplicate issue, please move it to where it needs to be.

I have a Metro PCS Kyocera Hydro XTRM. I rooted the phone and it was fine. I will be the first one to tell you i am a major newbie when it comes to smartphone tweaking. I have been playing with electronics for years, and can pretty much build a desktop computer but newbie when it comes to android devices. So upon suggestion from a dev, I downloaded an app from the play store "BootUnlocker."

As Soon as I rebooted my phone, BAM! It gets stuck on the METRO PCS screen and stays there. I have pretty much tried everything I can think of. I have removed the battery a billion times and tried to hard reset the phone numerous times as well. And now, it won't even turn on but the LED power light on the front flashes when it's plugged in. I was thinking of trying Odin but when I plug the phone into the computer's USB does absolutely nothing...doesn't read a thing.

I am hoping someone will be able to help with this soon as I would really like to know how to go about recovery on a phone that is completely Hard Bricked (as mine is now). If anyone has any suggestions, or has recovered a hard bricked xtrm, I would be so very thankful for your input.
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes