Remove All Ads from XDA
Honor View 10

[Q] Debug Battery Drain -

127 posts
Thanks Meter: 52
By smartxdev, Senior Member on 31st May 2014, 01:07 PM
Post Reply Email Thread
I'm using s4 mini LTE I9195 with CM11 M6, f4ktion 1.4.0 kernel, BN3 modem, TWRP 2.7 recovery

All was working fine, average battery drain on idle was 1%-2% (not great, but fine), and suddenly it rocketed to drain 15%-30% per hour.

I usually use Android Tuner's battery measure stats to track drain statistics over time.
After checking it, I"ve noticed that it () the drain) started in the middle of the night.
So it's not due to "I launched this App, and then..." It just went nuts on it's own...

I've checked which process is to blame and the first one with max battery consumption is: (with KitKat logo) followed by Android System, then Screen, and then all the usuals.

I tried to do reboots, disable wifi/nfc/rotation/data/sync/anything else/kill user apps - no effect ...
It still drains about 20% per hour on system and systemui for the whole day now
And I have no idea what causing it / how to revert it...

So, do you have any suggestions on how to trace this bug?
What to search for in logs?
Any thing else?

I'm not a big pro on android OS subsystem, so advises are welcomed!
31st May 2014, 06:46 PM |#2  
Junior Member
Thanks Meter: 0
I'd love to help, but I actually stumbled upon this thread while googling to help myself

I'm using Note 2 (N7100), running CM11 - newest nightly (although I flashed it today, after slightly recharging the battery once I noticed the problem) and Devil3 kernel.

I'm having the same issue - yesterday everything was fine, I've left the phone to charge over night and display time as usual and in the morning nothing seemed out of the ordinary, until 6 hours later. After those 6 hours my battery was fully depleted (whereas normally lasts whole day and is not even close to being depleted). and Android System seem to be the problem for me too.

I've also tried turning off some functions, uninstalling some apps, turning off notification privileges for others. Even, as said earlier, flashed newest nightly. Nothing helped. Using phone with without flashing Devil3 kernel didn't help.

Anyone have any ideas?
31st May 2014, 07:42 PM |#3  
Flag Somewhere
Thanks Meter: 37
Just try to flash stock software and again CM.
1st June 2014, 09:32 AM |#4  
Senior Member
Thanks Meter: 97
Try a older version of CM11, and if stability is a priorty stay on CM 10.2
1st June 2014, 12:05 PM |#5  
OP Senior Member
Thanks Meter: 52
OK, so I've tried a few things, and had a few surprising outcomes:

I've analyzed the CPU load with various tools, as Android Tuner, OS Monitor, and All-In-One Toolbox.
Most of them reported Android System using 30% CPU, and using 25% CPU, all on the highest frequency.
But All-In-One Toolbox recognized top process instead of Android System as Lockscreen android process, so maybe there is a hint there...
(and I don't use any custom lockscreen stuff beyond stock CM's one)

So, backed up the current troublesome system (let's call it BKP_NEW), just in case, and decided to restore a full NANDroid backup I had from a week ago (and the issue is just from yesterday).
Restored all 6 partitions (/system, /boot, /cache, /efs, /modem, /data), rebooted, and....
...The issue was still present! Crazy battery drain just as before!

Very confusing... Then I went for a factory reset - it fixed the issue, but I have to start from scratch with all the SW installs and config, and I don't have a week to waste setting everything up again, and potentially running into the same issue some time later.

So, I've decided to move further back, and restored a two week old NANDroid backup > reboot > No issue presents
But it was just too weird, since the delta between 1-week old and 2-week old backup is infinitesimal.

So, out of curiosity I've decided to restore the BKP_NEW (the one of the system with the issue present)... and after the restore it works just fine! (WTF?!?!)

After thinking on it for a while, my conclusion is that there was some problem with some part of system that was wiped/fixed in TWRP's Factory Reset, but is not touched/overwritten during the NANDroid 6-partition restore.
But again, this is just my assumption, need someone more knowledgeable to confirm this possibility...
(maybe @ne0zone75 can advice on this?)

Since that, all is working fine (at least so far).
And if my assumptions are correct, @Ksenios, you can try to do this, and still have working system with all apps and configs (If youre comfortable with recovery / backups management).
The Following User Says Thank You to smartxdev For This Useful Post: [ View ] Gift smartxdev Ad-Free
Post Reply Subscribe to Thread

battery, cm11 battery, debugging, drain battery, i9195

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes