Remove All Ads from XDA

T-MOUS S-Off on newest hboot 1.57.0000(what I did)

22 posts
Thanks Meter: 3
By Graymalkin626, Junior Member on 26th May 2014, 08:01 AM
Post Reply Email Thread
Let me start off with I think I got lucky. Try this at your own risk. I locked my bootloader and turned my security back on for a TMOUS warranty exchange for the dreaded purple tint in camera. I received my replacement only to find out that in fluorescent lighting the replacement HTC ONE M7 had a greenish tint but only under fluorescent lighting. So I am getting another replacement sent for free. This is where my troubles begin. I decided to unlock my bootloader for my original phone again and root it so I can set everything up again for daily use. I got through all those steps fairly easy. FYI: original phone is on newest TMOUS OTA_M7_UL_K44_SENSE60_MR_TMOUS_5.14.531.1_R-4.19.531.10_release_373019xng22l97gj5szmwv. I then relocked the phone and tried to flash RUU Zip M7_UL_JB43_SENSE50_MR_TMOUS_3.24.531.3_Radio_4A.21 .3263.03_10.38m.1157.04_release_336982_signed_2_de in order to achieve s-off again but to no success. Hboot 1.57.000 with S-ON wasn't having any of it I guess.
I unlocked bootloader and relocked bootloader several times trying several different methods to no success. Oh, my recovery was TWRP At some point I realized that if I was going to return this phone I needed to get s-off again to remove tampered flag and actually lock phone instead of relock. I happened to come across a stock rom that I decided to install in hopes of accomplishing S-off. Stock 3.24.531.3 was the rom. Long story. I know. So here is what I did;

Unlocked bootloader
Flashed TWRP and gained root using WinDroid Universal HTC Toolkit
Installed Stock 3.24.531.3 ROM via TWRP
Phone would not fully boot past HTC ONE Animation screen
powered down and powered back on into bootloader
relocked bootloader and rebooted bootloader
unlocked bootloader again
Phone now booted completely into the stock rom I flashed
Proceeded to use firewater for S-off
Didn't work first time
Powered down phone by holding power button and rebooted normally
Tried firewater again and to my luck the SOB worked and I am S-Off again on newest HTC One TMOUS with an older Stock 3.24.531.3 T-Mobile rom

I'm sorry if I have no links to anything I mentioned but I am new to this so I don't really know how to link to other stuff I found on the site. Thanks to all the great people whose tools and rom I used to achieve S-off again.
26th May 2014, 08:52 AM |#2  
OP Junior Member
Thanks Meter: 3
Prior to doing those steps firewater would not get past the first chugging stage.
26th May 2014, 09:06 AM |#3  
Senior Member
Flag Melbourne
Thanks Meter: 98
If you got the chugging message you were always going to be able to s off it. Firewater isn't worried about the hboot so much as the version of your cpu as to whether the exploit will work on it

Sent from my HTC One using XDA Premium 4 mobile app
26th May 2014, 11:23 AM |#4  
OP Junior Member
Thanks Meter: 3
It would get to the chugging and sit there for bit then kick the phone back to root command. It didn't matter how many times I tried it would always do the same thing at the same spot. I would then have to reboot the phone and try again but no success. I'm just sharing what I did and worked for me. Clearly the exploit didn't want to work before I did the steps I took. I wouldn't have spent almost 30 hours of reading and trying to fix the problem I caused otherwise. Maybe it was a fluke or dumb luck. I don't know.
1st June 2014, 08:08 AM |#5  
Senior Member
Thanks Meter: 35
Where can I find this stock rom?
1st June 2014, 05:07 PM |#6  
Senior Member
Thanks Meter: 35
Nevermind this did not work.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes