Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Okay so yesterday I was in the process of updating my One X using the manual update from the HTC website;

I followed all the steps and I got as far as actually updating my phone then the wizard tells me that my USB disconnected and the update cannot proceed. Now at this time, the "htc" logo was showing in gray. Not the usual one you see at boot up. After a while it came off and now my phone will not power on for anything. There's no led light either when I plug it in. Also, when connected to my laptop, windows gives me the message that the usb malfunctioned and it cannot recognize the device.

I don't know what to do. None of the methods I've tried have worked, I've tried the power button and volume down button and also taking out my sim card.
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes