Remove All Ads from XDA
Honor View 10

[Q] Softbricked (kind of) XT907 on Verizon

23 posts
Thanks Meter: 2
By LockdownInc, Junior Member on 1st June 2014, 06:21 PM
Post Reply Email Thread
Hello all,

Here's my situation; I have two rooted Razr M XT907s on Verizon. These are my kids' phones, and I haven't touched them in over a year. One was prompted for the OTA KitKat update, which was accepted (before I remember it was rooted). It appeared to be going well, then went into the recovery mode (Android on back with exclamation point over him). Now it continues to cycle through showing the red Moto logo for about 2 minutes, the black screen for 30 or so seconds, then the Moto logo again, then black screen, then Android on his back with exclamation point above him. It stays on the recovery screen for about 5 minutes then starts the cycle all over again.

I can get into the Recovery menu, and have tried to reinstall firmware from the SD card. The most recent attempt was the Blur_Version.98.18.94.XT907.Verizon.en.US (downloaded from link on XDA). This showed the most promise, but aborted after the Amazon Market app came back with "unexpected" contents. All other Recover menu items fail as well and return to the (failed) boot sequence I described above.

I have tried using RSD 6.1.5, but apparently it can't see the phone, plus the AP Fastboot menu/screen only responds by going into the boot loop regardless of what is selected.

I've updated the Motorola drivers, and can hear the phone connecting and disconnecting to my computer as it cycles the failed booting up. Interestingly, my computer is connecting to the phone only during the black screen segments; when the Moto logo or recover screen is displayed, the phone disconnects from my computer.

I'm no expert with this, but through XDA's forum's instructions over the years, I've been able to successfully root multiple Razrs and tablets, and Galaxy S4s, including updating them as newer firmware has been released (I've decided to stay away from the 4.4.2 update on my rooted S4 for now). However, for the life of me I can't figure out how to either return to the firmware this XT907 had yesterday, or plow through and update to the 4.4.2 update Verizon wants on the phone.... BTW, if I remember correctly this phone had debugging active before the OTA attempt.

Here's the info regarding the locked-up phone (taken from the identical rooted XT907, since I can no longer get into this phone):

Any help is much appreciated; this phone is about 18 months old, so warranty is out of the question...
2nd June 2014, 12:34 AM |#2  
LockdownInc's Avatar
OP Junior Member
Flag Naples, FL
Thanks Meter: 2

I was able to get into AP Fastmode (finally) and able to flash the VRZ_XT907_9.8.1Q-94-1_CFC xml file via RSD Lite (after removing the "getvar" line). The phone was restored to it's factory state with Android 4.1.2 with System Version 98.30.1.XT907.Verizon.en.US (unrooted) installed.

The best part of this exercise is that anyone that had a rooted Razr M XT907 (with Verizon) and mistakenly attempted the recent OTA to 4.4.2 which resulted in a frozen or boot loop, now fully knows there is a safe way out of the mess...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes