Remove All Ads from XDA
Honor View 10


43 posts
Thanks Meter: 5
By slgdad, Member on 31st May 2014, 08:59 PM
Post Reply Email Thread
I updated my system to 4.4.2 KitKat ota. Now I can't get my phone to root.. I have tried Odin and chainfire root method and it says pass but it won't root or install SuperSU any help would be greatly appreciated.. Thanks
31st May 2014, 10:03 PM |#2  
jwigley24's Avatar
Senior Member
Flag Ohio
Thanks Meter: 58
To root u need to flash a recovery thru odin and then boot to recovery and flash superuser
1st June 2014, 12:24 AM |#3  
OP Member
Thanks Meter: 5
I was told to flash philz recovery through Odin and check the root option. But I don't see that option! So do I need to flash SuperSU through Odin or recovery?? Thanks for the info..

Sent from my LG-US780 using XDA Premium 4 mobile app
1st June 2014, 12:52 AM |#4  
metalfan78's Avatar
Senior Member
Flag Lakewood, CO
Thanks Meter: 2,483
I flashed it through recovery.
2nd June 2014, 03:46 PM |#5  
JoHnNYBlaZE716's Avatar
Senior Member
Flag Buffalo
Thanks Meter: 2,086
Donate to Me
You need to Odin recovery of choice (I recommend philz latest) boot into recovery, and flash the SuperSU zip file, boot phone back into system, open supersu (if it force closes go into play store and update it) do necessary updating and disabling knox and viola you're rooted. Hope I helped.

Sent from my Sprint Galaxy s3 rocking Bilgerryan's Wicked X Rom, with the fluidity script, tweaked out with a bunch of Xposed modules, powered by Ktoonsez KT747 Kernel
2nd June 2014, 11:51 PM |#6  
Thanks Meter: 11
I did the same thing suggested here and it worked just fine for me. Flashed Philz and then the chainfire root and then got myself the Wicked X rom and Im never going back to stock except for the theme look
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes