Remove All Ads from XDA

[Q] Rooting Samsung Rugby Smart on Linux

1 posts
Thanks Meter: 0
By dkz999, Junior Member on 3rd June 2014, 07:05 AM
Post Reply Email Thread
Hello all,

I am a total newbie with mobile technologies, but know my way around a linux-box alright.

I just got a Samsung Rugby Pro through an upgrade at ATT.

My goal is to run Ubuntu touch as my main OS. I know some people think this is a silly aim, but its my money, so for the sake of simplicity, can we just agree that it is a goal?

I have been doing every backflip I can find to root this thing. Or flash it. Or do whatever is necessary to enable fastboot via the linux terminal.

The adb install I have works just fine (i.e. it detects, can restart it, etc). I have tried messing with the 51/71/99 android.rules in udev many, many times. Fastboot will not recognize the device. I have loaded the device into the bootloader screen various ways (via adb, via volumedown+home+power before and after plugging it in) ; no luck.

I figured it may be because the phone isn't rooted. This has led for my current root quest.

Using linux, and not having current access to any other OS's, I haven't been able to use Odin, or any of the other (likely scan) knock-offs. I have heimdall installed, and for the bloody life of me, though it says its working, even when the phone is in boot-loader, it doesn't do anything once the b*stard restarts.

I have tried downloading what feels like a hundered scrips,'s...etc, etc. No luck! Whenever I try to install the update from the SD, it says there is an error in verification. As far as I can tell, there isn't a way to do it during normal operation; not that that would particularly help.

I have also tried a zRoot application, and a host of others...most of which all require root access?

Perhaps this is a simple deficiency in my understanding of this whole process, but there seems to be a bit of a loop of which one is needed first; root or cwm. I am spinning round and round; my cat is looking at my chain smoking funny and my gf says I stink.

So here I come to you all. How the hell's this done? If anyone has successfully rooted the Rugby pro on linux, I would be eternally greatful for the help. If you know how to go all the way to ubuntu-touch, you will have a cat and a lovely lady also eternally greatful.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes