Remove All Ads from XDA
Honor 9 Lite

[Q] Optus 4.4.2 GPS Issue

2 posts
Thanks Meter: 0
By cyberboblouth, Junior Member on 3rd June 2014, 10:25 AM
Post Reply Email Thread
Hey guys,

I live in Australia and as such I have the D802T.

Not so long ago the phone offered offered to update to 4.4.2 from JB I guess. All was well except GPS became very intermitent. After some mistakes with applying TWRP I eventually got a French Vodafone 4.4.2 ROM loaded (via TOT method on this forum). With this ROM i had no GPS issues but lacked 4G. After more searching I changed a line in "build.prop" and now have 4G, I also had to update Touch settings for 'Knock On'. I managed to find the 4.4.2 Optus KDZ file and created a ZIP firmware, but after applying I still had the GPS issue so went back to the French TOT ROM.

I called Optus and they have no idead so I wanted to know if other people had experienced GPS issues with the Optus branded 4.4.2 update?

Also, does anyone have the JB 4.2.2 Optus ROM? I have searched but only fidn the latest 4.4.2
6th June 2014, 05:23 AM |#2  
OP Junior Member
Thanks Meter: 0
My USB OTG cable arrived and I found TWRP can access a USB drive, after performing a backup I have installed Cloudy. This has solved my lack of sound when typing, came with the option to use LTE 4G and the GPS seems OK but I will know more when I go home.

While I was fiddling I also tried to change my, I accessed system/media and changed the file but the animation stayed the same. Eventually I found a folder called 'cust' and in there were folder startup and shutdown in which were the animations. This may be just down the SFR TOT ROM I was using.

Things I would do different, and I am not a novice at this:

1. Check the exact D802 version, in Australia it's D802T and when I installed TWRP for the International D802 I was no longer able to boot into Android and use my phone - bu**er!
2. With TWRP working back the ROM onto a USB stick, just in case you choose to wipe the whole phone while frustrated - yes I did this, again, bu**er! I did find that the USB stick must inserted while the phone is working (booted fully into Android) for its first use. It then happily mounts in TWRP
3. Choose a ROM that is confirmed for your model. I wanted Pardus HD but it just doesn't boot for me with the D802T. Cloudy works nicely though.
4. Enable 4G by choosing mode 'GSM/WCDMA/LTE Auto' by going System settings > Tethering & Networks > Mobile Networks > Network Mode. If the option isn't there Google the fix but I used ES File Explorer (phone rooted & system mounted as RW) to edit the build.prop file in 'Device\System'. Changing '#ro.telephony.default_network=9" to "ro.telephony.default_network=11' I am on Optus and the post I read also offered 13 as an alternative number. Cloudy offered the LTE straght away.
5. If the 'Knock On' is playing up then go into LG Hidden Menu (Google this) and then 'Settings\Update Touch....'

I hope this information may help somebody out and many thanks to XDA and contributors for the information I read that helped me solve my issues.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes