Remove All Ads from XDA

[Q] Link2SD:2nd partition shown but still not working

7 posts
Thanks Meter: 0
By Androhelp, Junior Member on 6th June 2014, 08:37 PM
Post Reply Email Thread
I tried to install Link2SD in Micromax A58 as the internal storage is very low and need to install some more apps. Already rooted and installed Link2SD to use the ext4 2nd partition of my 8 GB SD card. After trying with all possible ways, couldn't get it worked. All the time it was showing error--

"Mount Script can not be created. Mount: No such file or directory"

Previously even the 2nd partition was not shown as mounted in the storage info of Link2SD but after modifying the in /etc path, the storage info now atleast showing the 2nd partition as mounted. My looks like below--

/system/xbin/daemonsu --auto-daemon &
mount -t ext4 -o rw /dev/block/mmcblk0p2 /data/sdext2
mount -t ext4 -o rw /dev/block/vold/179:2 /data/sdext2

Now, the problems are as below--

1) Installed multiple applications but none of them are actually linked to SDcard. The Link2SD shows them as 'On SD Card' and just after installing 9-10 small applications, the internal memory is now full. If I go to 'Create Link', it is giving error '/data/sdext2 mount not found'.
2) When try to recreate mount script and choosing 'ext4' as parameter, it still throws error

"Mount Script can not be created. Mount: No such file or directory"

It seems that even though the storage info shows the 2nd partition as mounted, but system couldn't identify it somehow. So, Link2Sd is not working at all.

Please help and advice further. Thanks a lot.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes