Remove All Ads from XDA

No charging when in Android, charges when turned off

254 posts
Thanks Meter: 30
By BigladUK, Senior Member on 6th June 2014, 01:58 PM
Post Reply Email Thread
Strange problem that started a few days ago ( been using the Z2 for over a month now ), I noticed after a long drive the battery was at 17% even though it had been plugged into the Magnetic Charger I have all the time. The lightening icon was present but no charging was happening.

I thought no more of it until last night when I left ( as always) my phone on in the Sony Dock overnight and realised in the middle of the night it had run out of charge and turned itself off. So the magnetic charging points don't work....odd

So I've resorted to regular usb charging but this only works when the phone is off and not when on

I assume the phone is faulty but wanted to consult you guys incase I'm missing something

The phone is stock ( was O2 branded but flashed a while ago with generic UK firmware )

I've tried a factory reset in the OS menus but has mode no difference

Thanks in advance

6th June 2014, 08:10 PM |#2  
Senior Member
Thanks Meter: 14
have you tried a different charger?
7th June 2014, 11:13 AM |#3  
BigladUK's Avatar
OP Senior Member
Thanks Meter: 30
Yeah it looks like me USB charging problem was the cable ( I haven't really used cables since getting the magnetic charging adapters ) but the Magnetic Charging port is defiantly not working, it's registering that it's connected and thinks it's charging but gets a message after a short while saying the charging is too slow and it's discharging faster than it's charging so I assume it's a hardware problem.

I've raised a case in Sonys website and will be sending it back to them for a fix, perhaps they might replace it with a bootloader unlocked version LOL

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes