Remove All Ads from XDA
Honor 9 Lite

[Q] can't copy/move to INTERNAL memory

8 posts
Thanks Meter: 2
By MisterVolum, Junior Member on 1st June 2014, 03:30 PM
Post Reply Email Thread
hello everyone. Everything was fine, until i decided to restore the phone to it's factory settings, because of too much battery drain.
My phone is rooted, it is stock 4.2.2, and i have 2 file managers: ES File Manager (for it's LAN possibility) and Root Explorer 3.1.7 for it's speed. And also have the stock file manager.

After the factory restore, i noticed that i am unable to copy/move files to internal memory from MicroSD via ES File Manager and Root Explorer, and Solid Explorer, though i granted them root rights via SuperSU. Everytime i try to do so, i get this message:
Copy failed to /storage/emulated/0. I tried converting this apps to system apps, using Titanium Backup, but no succes
i also can't copy/move anything to folders located inside /storage/emulated/0, like: Alarms, Android, backups, Books, clockworkmod, DCIM, Documents, Download, fonts, Movies, Notifications, Pictures, Podcasts, Sounds...
interesting is that i can create folders inside these ones, but i can't copy/move anything there.

Moon+ Reader also can't create its backup files inside /sdcard/Books/MoonReader/Backup/ with a message of open failed: EACCES (Permission denied), but there's no problem when backing-up files on 32GB MicroSD.
uTorrent application also can't write data inside /storage/emulated/0, giving the same error: EACCES (Persmission denied).

Another very interesting thing is that i CAN copy/move files to /storage/emulated/0 via stock file manager.
I also CAN copy/move files via ES File Explorer, Root Explorer to any other folder located outside /storage/emulated/0.

i tried changing the permissions of /storage folder to rwxrwxr-- using Root Explorer, and it changes. I can also change the /storage/emulated permissions from ---r-x--- to rwxrwxrwx, but despite this, i can't copy/move files. After phone reboot, the permissions of /storage/emulated restores to ---r-x---.
Can't change any permissions on /storage/sdcard0, /storage/emulated/0, /storage/emulated/legacy, though they are respectively: rwxrwxrwx, rwxrwxr-x, rwxrwxr-x. I get: permissions change was not successful. Please note that some file systems (e.g. SD card) do not allow permission changes.

Any ideas on a workaround ?
Thank you for any help you can provide in this situation.
8th June 2014, 02:45 PM |#2  
OP Junior Member
Thanks Meter: 2
i fixed the problem by installing a modified stock kernel from here because i had high battery drain (up to 3% per hour) in idle mode, with gps, sync, gmaps, nfc, 3g - all turned off. Sometimes i had 0.5% per hour, sometimes 2% per hour, sometimes 3% per hour. Restarting the phone sometimes fixed the drain, other times - didn't.
Will see if it's the fix for the battery also.

moderators, please add a "fixed" to the title of the thread.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes