Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Greetings dears XDA members!

I read out many many many of posts before postings, and also used "search" feature in order to find a topic like mine, but with no success.

Well, I start to explain my problem..


A few days ago, my Samsung Galaxy Tab 2 (10'1)'s tablet caused some reboots without really beings really very common, but now .. reboot frequency has greatly increased since yesterday day.

A quick check using the "Reboot Checker" (you can find it through the Google Playstore:, and I can see that reboots are really common now as showed by the log reports showed in "RebootCheckerLogReports.png"'s file attachment to my post.

So.. What I do of specials before reboots are produced??

Hmm.. Really nothing, really:
  • I always deactivate the "AutoUpdate" for Apps from Google Play
  • Before reboots are encountered, I not installed any applications
  • I never install applications and Games out of Google Play official market
  • I just play to few games (like usually I do): Fantasica, Rage of Bahamut, Legends of Cryptids, Arcana Magic, DarkLords, Bingo Blitz, Chaos Drive, and that's all..
  • All applications I install from Google Play are recommanded/unlocked by AppGratis (and other websites like this)..
  • I never rooted my system (And I see now, I'll have to do on Day 1 of the purchase of the tablet ... since no-rooted an Android System doesn't permit recovery things at an advanced state..)

So, due to that reboot, I firstly thought that was a memory storage issue like, not enough diskspace. (with all that AppGratis applications, I have less disk storage memory indeed xD).. Then, I uninstalled some apps which I installed some months ago and I less used..

Bad Tought: Reboots hasn't been discontinued... ** sigh **

I think then it was update of Google Apps (like Google+, Google Talkback, Google Mail, Google Youtube etc..), so I updated them from Google Play..

Again, Bad Toughts: Reboots still here.. ** big sigh **

Well.. my hope was then at this state ported to Internet...

So I read many topics on "Unattended Reboots"..

And I finally found something of VERY useful.
On here:

Glad I find that StackExchange question, I now that the "su" (Linux SuperUser if I well understand my Linux course), is not possible under a non-rooted Android (that a stupid behavior for an Operating System that.. But.. Well.. I continue)..

So, I started to think how I will be able to catch this file... and save in a readable folder..

Hopefully, 1 year ago I installed an app named: "ES Explorateur de fichiers" (find out this here:

And this great apps was letting me accessing to the wanted file: /proc/last_kmsg
(I shared it to my DropBox linked account, and then I was able to open it on my Windows 7 Computer).

I then provide the log here:

So.. In the meantime, I started to analyze the log, and visiblely, my main (and sad) problem is that my Internat Flash Drive is dead.. Since I/O errors are the only main reason to Kernel Panic and reboots..

Well.. My warranty is void since months now.. (well well.. well..)

I then can't RMA the product (the tablet if I understand well).

I don't want wipe datas/cache and anything before try some new XDA tricks.. (I don't expect do much like that, but hey.. Hope is Hope.. my datas aren't important, it's true, it's mainly Game Saves and Unlock keys for AppGratis recommanded applications, but then, if I wipe datas, I will lose ALL of theses free unlocked apps.. This is a thing I doesn't really want, if you mean what I want mean..)

... so... I started to think what we can do for fix bad sectors on Linux (since Android is based on Linux and Dalvik if I (again) understanded well).

I hink that fixing bad sectors allocations it will fix the problem, since if I analyze my Internal storage (called sdcard0) there is sometimes the scan is finished without reboots!

So I was directed on XDA-Developers (which I know that you are famous for your system hacks and morever) here by Google :

I saw this post:

And then a quick search on Google again on the words "Android + fsck the filesystems through adb shell" redirected me to that excellent post:

This is a great information, but... I don't know how to go in recovery mode from my Galaxy Tab 2. So.. I searched on the web for it, and found that:

So.. I started blink my eyes, and go for hard work, and since I already in the past installed the Android SDK (for develop personal mobile apps with Titanium Studio, Adobe Cordova, PhoneGap), and do all update especially installed adb..):

Once plugged to my PC and booted in recovery mode, I was able to access to the famous recovery mode
(This was so exciting due to the fact I like the way of it look: especially the Android bot unfixed in the background ^_^).

So, on my PC I started to open a command line in the folder: C:\SpecialAppDevelopper\Google Android SDK\platform-tools
(this is where I installed the Android SDK)
and typed this:

C:\SpecialAppDevelopper\Google Android SDK\platform-tools>adb devices
This showed me that:


List of devices attached
c16073dc82dc68f recovery

So it worked! My device was successfuly attached to ADB !! What an excitation !

I then continued typing other commands:

C:\SpecialAppDevelopper\Google Android SDK\platform-tools>adb shell
This output that:


shell@android:/ $

Good. Now In this shell access I typed :

mount /system
Not good here since all I get is a USAGE warning with options recommanded. (like a return of a MAN command..)


shell@android:/ $ mount /system mount /system Usage: mount [-r] [-w] [-o options] [-t type] device directory

Well.. tryied the next command in order to listing report file system disk space usage:

all I got as output was occuped space, not the path of the mounted images...

Now, I started to reanalyze my last_kmsg log in order to find which path they are..

I found it!
[ 94.965454] C1 [jbd2/mmcblk0p10]

So... I started to return to my ADB commandline window and typing:

ls -l /dev/block/mmcblk0p10/
This outputed that:


/dev/block/mmcblk0p10/: Not a directory

So as it looks a good path, I started typing this:

e2fsck -n /dev/block/mmcblk0p10
And even if it is the right path (one of the right path, I don't tryied with others...), I got this output:


e2fsck -n /dev/block/mmcblk0p10
e2fsck 1.41.11 (14-Mar-2010)
e2fsck: Permission denied while trying to open /dev/block/mmcblk0p10
You must have r/o access to the filesystem or be root

Yeah... I'm not root, cool, even in a Recovery Mode on a non-rooted Android Operating System (Logic in a way, but very difficult to fix problems then occuring then )..

Ok.. So, My mind blinked in an idea when looking at this: You must have r/o access to the filesystem or be root
So.. This is not needed to be root for executing a e2fsck command in Recovery Mode, but in that case I need having access to the filesystem in a READABLE mode. OK.

So, Hope started to bringed back, and I made new Google research, on "mount an android filesystem in recovery mode"

I was then directed here:
- - Very complex for me, I don't want brick my system.. So I skipped.

- -

So.. For being root in recovery mode, I can also type the simple command: adb root

Ok... What I do..
And, as expected it doesn't worked for me:

C:\SpecialAppDevelopper\Google Android SDK\platform-tools>adb root
adbd cannot run as root in production builds

Ahaha.. Well starting to be hopeless now.. I'm finally just an user of my OWN tablet.. How it's ridiculous.

This is a bit tedious, because all my future Google research in order to find how to simply "mount" a filesystem as readable (and then replace it as it was after the process..) aren't really efficient, I founded nothing of useful..

Nothing usefull but that:

So, it seems I will be able to mount as readable a filesystem through Production Recovery Mode (the one I'm forced to use then..)..


Well.. Now, since I don't know what I can type for mounting my filesystem... as readable just for make a e2fsck... Seriously..

Help me dear gurus, i'm completely lost because my Linux knowledge stop here !
Attached Thumbnails
Click image for larger version

Name:	RebootCheckerLogReports.jpg
Views:	16
Size:	150.9 KB
ID:	2791907  
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes