Remove All Ads from XDA

T-Mobile GalaxyS5 m900t LTE issue

50 posts
Thanks Meter: 8
By Alan Shore, Member on 10th June 2014, 03:59 PM
Post Reply Email Thread
Just joined from the iphone world to the android world after about 3 years. Wow. =]

Anyway, just bought the phone yesterday, activated it an within 15 minutes had it rooted phiz recovery and and installed AllianceRom 3.1 on it.

I've had a bit of an issue, It will not go LTE. It only stay on 4g or go to E,, H+, my friend who has an iphone, same provider and same service, his phone shows LTE in our same location at his desk but mine will not go above 4G.

Did I do something wrong with the root process? Anyone ever seen this issue? I'd say its an issue with the service but when you have a friend with the same provider and his phone is showing LTE, it begs to ask questions

Thanks all,
11th June 2014, 02:44 AM |#2  
do a speed test and u will know, i think on yr ROM 4G = LTE, H+ = 4G, also check yr APN too.
11th June 2014, 07:13 PM |#3  
OP Member
Thanks Meter: 8
Got it Hope this helps new rooters
Originally Posted by koolboyztn

do a speed test and u will know, i think on yr ROM 4G = LTE, H+ = 4G, also check yr APN too.

I checked it out, I found that it was a combination of a couple of things,

When I bought the phone I rooted it immediately, didn't officially update it or anything. I was working on the older radio with the newer Alliance rom which required the latest radio.

The only way I was able to fix it was use Kies, update it, which put it back to stock recovery and stock rom. Reroot using Odin and install Omega's rom. It would of probably worked fine with Alliance rom but I saw a couple things I liked with Omega.

When I updated stock I saw LTE. Which told me that it was a radio issue, I tried updating the radio manually but it failed so I just let Kies do it.

All settled and done, it's purring like a kitten now Thanks Koolboyztn for your suggestion
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes