Remove All Ads from XDA

[Q] xcover 2 bootloop after dba install location change

2 posts
Thanks Meter: 0
By heliogabal, Junior Member on 31st May 2014, 06:50 PM
Post Reply Email Thread
I'm running deodexed build from this post: and CWM bootloader. I'm using link2sd and 16GB external CD card.

Strange things started to happen (I think) after using my phone in the swimming pool. Apps from my external card vanished and I couldn't fix this issue, so finally formatted SD card (minitool didn't work, partition toolkit did). Meanwhile every now and then "no place on disk" error while installing apps popped up. Approx. 400 MB of internal storage was free...

After format things started to look promising, but "no place on disk" error still bugged me, so I thougth about workaround, and tried adb shell pm set-install-location 2. After restart I got bootloop. Tried several options and finally was able to flash firmware with odin 1.85. While I was at it, I flashed bootloader with CWM mod and odin 3.09. (Before flashing I was getting an error after restart and had to reboot manually:

E: failed to verify whole-file signature
E: signature verification failed

). Well, that worked, and no data was lost, but my external card is unusable, link2sd warns me about my second partition not being automounted and every time I restart phone I'm in the bootloop again, having to flash firmware to be able to unbrick it.

I tried to fix second partition from within partition toolkit, but no luck, formated it, again, but now link2sd doesn't see it mounted at all (partition toolkit does). I've reverted install location already, set it to 0, and later to 1, but no luck... I mean it works, but doesn't solve the problems.

I'm running out of ideas. I backed up everything with titanium backup and I'm considering factory reset, but not sure if it will help at all...
14th June 2014, 09:54 AM |#2  
OP Junior Member
Thanks Meter: 0

I bought 32 GB SD card and replaced the old one. Formatted it and things seemed to work, but in roughly 50% of cases I couldn't install application due to "usufficient space on disk" error.

And another issue: yesterday my phone hung, so I restarted it. Basically it entered bootloop, but starts normally as soon as SD card is removed. Recovery log says "can't partition non mmcblk device" regarding SD card.

It looks as if SD card was mountable only when fresh formatted, any application moved to it (link2sd) and things end up as described.

Tried to boot without SD card and insert it later when system starts, but no luck (card is not discovered at all).

I'm seriously considering selling this phone - without external space for installing apps it's next to unusable, and it seems I am not able to solve the issues with SD card.
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes