Remove All Ads from XDA

[SOLVED] Missing version-main number; trying to get back to stock

1 posts
Thanks Meter: 0
By slayerstzain, Junior Member on 15th June 2014, 01:11 AM
Post Reply Email Thread
EDIT: Well this is awkward. After posting this thread I found the solution. If anyone in the future has the same problems as me, just flash one of these
Apparently that was all that was needed.

Hello xda community,

First off, I apologize. I know questions like these get asked hundreds of times but after spending 3 days straight of digging through forum threads and making very little progress I've decided to just ask.

So I tried installing a custom rom on my HTC One. I did exactly what I usually do when flashing a new rom on my nexus 7. I had an unlocked device with the latest twrp recovery. I did an advanced wipe (which included internal storage), then I did an adb sideload to flash the rom. I must have done something wrong because the flashing didn't work and ever since then I've been trying to get back to stock rom.

I've tried running both the 3.04.651.2 RUU and the 4.06.651.4 RUU posted by O.M.J and neither worked. I've tried flashing the Guru Reset M7 Sprint 3.04.651.2 rom found on htc1guru. Twrp said the flashing was successful yet when I booted up the device it would get to the lockscreen and when I tried to unlock it, it would just show the HTC logo. After that it would endlessly reboot itself over and over. I've tried flashing the Android Revolution HD 31.6 rom and I got the same problems as when I tried to flash the htc1guru stock rom.

I can get into both the bootloader and twrp recovery without any problems so I figure not all hope is lost. Below is info about my phone. As you can see the version-main number is missing, though I don't know how important that is.

(bootloader) version: 0.5
(bootloader) version-bootloader: 1.57.0000
(bootloader) version-baseband: N/A
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: X
(bootloader) imei: X
(bootloader) meid: X
(bootloader) product: m7_wls
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0720000
(bootloader) cidnum: SPCS_001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4315mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-1f512bb6
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.037s
I'm not sure if it's significant, but I did manage to flash that custom rom today. It's the rom. I booted up the phone just fine (this is probably the only successful thing I've done so far).

Anyway, like I said I'm trying to get back to stock and I would appreciate any and all help. Thanks guys.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes