Remove All Ads from XDA

[Q] partition corrupted - any hope?

114 posts
Thanks Meter: 9
By mageus, Senior Member on 15th June 2014, 04:02 AM
Post Reply Email Thread
Nexus 10 16 GB

I took the 4.4.3 OTA, which worked fine. Then I flashed TWRP, which worked fine. Then I used TWRP to install SuperSU 1.99. Prior to reboot I wiped the cache. During this the Nexus turned off by itself. When I rebooted it got stuck in boot at the merging circles (it didn't hang, the circles kept moving).

- TWRP works fine
- ADB works fine
- /proc/partitions shows all partitions listed
- /dev/block/platform/dw_mmc.0/... shows all partitions listed, with correct hard links
- "e2fsck cache" partition says:

e2fsck: Superblock invalid, trying backup blocks...
e2fsck: Bad magic number in super-block while trying to open cache

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

- "fdisk -l" shows nothing
- "fdisk -l cache" shows the correct partition size
- fastboot erase cache just hangs at:
"<waiting for device>"

Running e2fsck on system and userdata is clean. e2fsck the other partitions (boot, efs, metadata, misc, param, recovery) gives an error, but I'm guessing they're not ext partitions.

I'm worried that TWRP hosed the cache partition. I could try to flash stock manually, but I'm worried that ADB won't see the cache partition (it can't even wipe it). If I can fix the cache partition i should be able to reboot while keeping all my data intact.

Any ideas?

Also, any EASY way of copying over all my data with ADB? I guess I could just ADB PULL the TWRP nandroid files?
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes