Remove All Ads from XDA

Galaxy S3 Randomly Died

34 posts
Thanks Meter: 1
By SirFunk, Member on 17th June 2014, 04:15 AM
Post Reply Email Thread
Hi all I have an old S3 that seems to have kicked the bucket. I am hoping there is some way to save it though. I have been running the last CM 11 milestone for a long while now. I just use the phone with an archlinux chroot to do some linuxy-things. I tried ssh'ing into the phone while I was at work the other day and the ssh session hung. Upon getting home the screen was black and wouldn't turn on. I tried pulling the power and restarting and it just hung at the CM boot logo.

It would boot into TWRP recovery or download mode but never boot. I eventually noticed in TWRP that it said my internal storage was 0MB large and found that the userdata partition was corrupt (e2fsck wouldn't work)

I've tried every combination of flashing a stock .tar and/or .pit file but nothing seems to change.

Here is the output I get when trying to repartition with odin:

<ID:0/003> Added!!
<ID:0/003> Removed!!
<ID:0/003> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> I747UCDLK3_I747ATTDLK3_I747UCDLK3_HOME.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Set PIT file..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> aboot.mbn
<ID:0/003> NAND Write Start!! 
<ID:0/003> FAIL!
<OSM> All threads completed. (succeed 0 / failed 1)
and heimdall:

heimdall flash --repartition --verbose --RECOVERY openrecovery-twrp- --pit ../sgh-i747-16gb.pit --no-reboot
Heimdall v1.4.0

Copyright (c) 2010-2013, Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:
Initialising connection...
Detecting device...
      Manufacturer: "Sasmsung"
           Product: "MSM8960"

            length: 18
      device class: 2
               S/N: 0
           VID:PID: 04E8:685D
         bcdDevice: 0100
   iMan:iProd:iSer: 1:2:0
          nb confs: 1

interface[0].altsetting[0]: num endpoints = 1
   Class.SubClass.Protocol: 02.02.01
       endpoint[0].address: 82
           max packet size: 0010
          polling interval: 09

interface[1].altsetting[0]: num endpoints = 2
   Class.SubClass.Protocol: 0A.00.00
       endpoint[0].address: 81
           max packet size: 0200
          polling interval: 00
       endpoint[1].address: 01
           max packet size: 0200
          polling interval: 00
Claiming interface...
Attempt failed. Detaching driver...
Claiming interface again...
Setting up interface...

Initialising protocol...
WARNING: Control transfer #1 failed. Result: -9
WARNING: Control transfer #2 failed. Result: -9
WARNING: Control transfer #3 failed. Result: -9
WARNING: Control transfer #4 failed. Result: -9
WARNING: Control transfer #5 failed. Result: -9
WARNING: Control transfer #6 failed. Result: -9
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Uploading PIT
ERROR: Failed to unpack received packet.
ERROR: Failed to confirm end of PIT file transfer!
ERROR: PIT upload failed!

Ending session...
Releasing device interface...
Re-attaching kernel driver...
I'm out of ideas, any suggestions?

17th June 2014, 03:42 PM |#2  
mattsternc's Avatar
Senior Member
Flag Cary, NC
Thanks Meter: 7
I could be wrong here, but it sounds like your eMMC Chip may have died. I don't have specific experience of this ever happening to any of my phones, but it just popped into my head as an idea.

17th June 2014, 04:04 PM |#3  
OP Member
Thanks Meter: 1
Yeah, this is what it sounds like to me. Anyone know if there is a way to verify this?

Sent from my Nexus 5 using XDA Free mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes