Remove All Ads from XDA

[Q] Cannot re root after 4.4.3 upgrade

133 posts
Thanks Meter: 7
By wardy277, Senior Member on 18th June 2014, 08:43 AM
Post Reply Email Thread

I previously had purity rom on my nexus 10. I decided to back to stock and use the xposed framework. So with 4.4.3 I flashed the stock images (manualy so it didn't wipe my sdcard partition), wiped data, cache and dalvick.

Stock 4.4.3 works fine, no issues here, but in acquiring root by flashing supersu update (both 93 and 99r3) root doesn't seem to stick. I can adb in and su from terminal, but when booting android supersu days it couldn't acquire root. I have tried other clockworkmod recovery and team win recovery so see if it was a bug with recovery, but no dice. Clockwork did occasionally say it lost root and press Yes to put it back, it did this on my nexus 5 and I still kept root.

I have even tried the universal nexus toolkit but that didn't work either. All methods I have tried have run the zip output fine, saying success.

Any ideas what's wrong. I assume I have done something wrong but can't find much information about root not working like this.
18th June 2014, 06:37 PM |#2  
Senior Member
Thanks Meter: 23
Did you try chainfire 2.00?

Link to Chainfire page
18th June 2014, 09:30 PM |#3  
XxLordxX's Avatar
Recognized Contributor
Flag Campinas
Thanks Meter: 1,496
Donate to Me

Some time ago I've faced the same issue as you, what worked for me was using an older supersu flashable zip and after flashing it I flashed the latest. Don't know if it was placebo or something, but always worked for me .

18th June 2014, 09:31 PM |#4  
sfobrien's Avatar
Senior Member
Flag Indiana
Thanks Meter: 394
I did the exact same couple days ago after running Omnirom. I used this odex stock image

After the initial factory wipe I wiped dalvik,cache,data, and flashed SU after flashing the ROM but before reboot. Using latest TWRP. Hope this helps.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes