Remove All Ads from XDA

[Q] Unable to delete files in /storage as root?

41 posts
Thanks Meter: 5
Post Reply Email Thread
After reformatting (keeping the sdcard partition) and reinstalling android on my rooted Moto X, Titanium Backup stopped working saying "insufficient free space". When I check space on the device it's got plenty.

As a test, when I tried to delete /storage/emulated/0/TitaniumBackup/org.mozilla.firefox-20140326-060005.tar.gz I get the error


rm failed for TitaniumBackup/org.mozilla.firefox-20140326-060005.tar.gz, Permission denied

Checking the file permissions, it looks like it's writable

1|root@ghost:/storage/emulated/0 # ls -l TitaniumBackup/org.mozilla.firefox-20140326-060005.tar.gz
-rw-rw---- root     sdcard_r  5048353 2014-04-10 07:58 org.mozilla.firefox-20140326-060005.tar.gz
But just to be sure, I ran

chmod 777 TitaniumBackup/org.mozilla.firefox-20140326-060005.tar.gz
Which didn't seem to make any difference

When I run mount, it appears to be writable.

/dev/fuse /storage/emulated/0 fuse rw,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0
Other apps are able to write to the sdcard partition, as best as I've noticed the /TitaniumBackup/ directory is the only one not working.

Is there anything else I can try other than completely reformatting my phone?
21st June 2014, 05:22 AM |#2  
OP Member
Flag Philadelphia
Thanks Meter: 5
I rebooted into recovery and opened an adb shell while my phone was in recovery.

From within recovery I was able to delete the TitaniumBackup directory with no problems.

After I booted back into normal mode, I cleared all app data for Titanium Backup from Settings > Apps > Titanium Backup and then started up the app again and everything worked!
The Following User Says Thank You to danherbert For This Useful Post: [ View ] Gift danherbert Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes