Remove All Ads from XDA

[Q] Chinese Clone Tablet PC (Onda) - Can you sideload a root & new CM bootloader?

1 posts
Thanks Meter: 0
By omendata, Junior Member on 21st June 2014, 08:50 PM
Post Reply Email Thread
Bought a quad core Onda clone tablet (AOC Leopard hardware designation) from China - yes i know, i know, it was a bad idea but the spec was so good i thought it might get me into the tablet fun everyone seems to be having - i repair em but dont really have a lot of knowledge on the software side of things for hacking these things - although after the last two weeks of hacking the thing I am becoming a bit of an expert.

Here is a link to the same one albeit with a different manufacturer made up name - as you can see the spec (Quad core, 1Gb ram, 16Gb storage and hdmi) is amazing for the price of £42 I won it for at the auction so it was more of a plaything to learn on than a big purchase for me.

I am pretty good with Linux so be as technical as you need to be.

Basically the thing buggered up when my mate plugged in the wrong power supply and thankfully it still booted albeit with the OS or bootloader I suspect corrupted.

It is stuck on the Onda loading screen leading to my assumption that it is in a boot loop.

I have spent the last two weeks trying to find drivers for windows , a compatible os and a way to get it restored - ahh the perils of buying chinese!!!

Problem I have now is that the sdcard slot is completely snafu due to my careless and fat fingered fiddling and to be honest a slight bit of temper with the thing after two weeks of head scratching - do you blame me!!!

I have managed to get it recognised by windows by trying driver after driver on the internet until i found one that worked - the perils of buying a no name chinese clone are myriad.

Without the sdcard slot the problem is now worse as i have to use the usb slot connected to the pc and sideload the apps and os but thankfully that is sorted now - Have installed the Android development Bridge - SDK toolkit and adb devices linux command was coming up with no devices but i figured it out with a lot of fiddling with the android ini file in the user profile and the dev id in system device drivers in case anyone else is trying to figure that one out - its a very obscure fix but it works.

So all is swoopy and seemed to be going well until i got the same error i was getting with the sdcard when i tried to sideload a new os - sideloads the new "" perfectly and even passes the file verification but crashes out with the fatal "unexpected error" have tried Onda official zips and Cyanogenmod flashes but i reckon the problem is because the system is not rooted and doesnt have the cyanogen bootloader installed even though i rooted it with supersu before it went up the khyber so in essence I need root to get the new os on and yes "shell su" command doesnt work as the device is only in sideload mode - only option on the 3e emergency recovery mode on the tablet is either reload from usb , sideload from usb as well as the usual clear cache, reset system and clear user data.

I should add that the hardware isnt snafu as I can see my old files and the operating system on the flash drive when i use recovery mode (power button / up volume combo) - load from sdcard option when i choose browse to sdcard - Linux always mounts the onboard flash as sdcard and an external sdcard as ext-sdcard on a tablet or smartphone - so i can select sdcard and then browse the main flash storage where i can see all my movies , development programs apk's and the Linux system itself but obviously cannot do anything else other than browse the thing for a ZIP to upload onto the \temp which is then extracted by the Emegency recovery environment - checked for verification - it then seems to prepare to install but fails with as you say the usual "unknown error" which i only assume is because I dont have root i cant go any further.

Oneclick root doesnt work.

Also tried the pad product tool v1.05 for direct flash to the tablet using Ainol Novo 10 Captain firmware and it wont even work.

Flashboot adb doesnt work.

Rockchip android tool doesnt work.

Kinda running out of ideas now!!!

Ok ok so what i need to know is basically - Does anyone know if it is possible to root and install a new bootloader from the usb sideloader - ie Adb sideload "filename".

And yes i have tried the pinhole reset button on the back of the tablet and the wipe system and reload option in the recovery menu so hopefully there are some good techies on here who know how to su the bootloader and reload the os or if it is even possible!!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes