Remove All Ads from XDA

Can't open play store...

1 posts
Thanks Meter: 0
By lozh79, Junior Member on 20th June 2014, 10:11 AM
Post Reply Email Thread
Hi all,

I have a 10.1 tab and for the past week or so I've not been able to access the play store. I've tried clearing the cache, rebooting etc but nothing I've tried works.

Does anyone have anything else I might be able to try?

22nd June 2014, 04:08 PM |#3  
Halogoop's Avatar
Thanks Meter: 4
Donate to Me
This problem has occurred to me on many devices before.
Some of the most common reasons are:
  • Date and time are incorrect
  • Device is not original (playstore manually installed)
  • Google play services corrupted

Try seeing if you have any of those reasons above.
Date and time is the most common for me. Also if these don't work please root your device and install a custom rom with playstore pre-installed.
22nd June 2014, 04:25 PM |#4  
dparrothead1's Avatar
Senior Member
Thanks Meter: 1,794
Go into "Manage App" and uninstall updates from the Play store.

Sent from my SM-T310 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes