Remove All Ads from XDA

[Q] Android Studio “install_failed_invalid_apk” error

1 posts
Thanks Meter: 0
By nadabro, Junior Member on 22nd June 2014, 10:40 PM
Post Reply Email Thread

Im trying to debug a app in Android Studio, but every time i run the app to the phone it says:

DEVICE SHELL COMMAND: pm install -r "/data/local/tmp/"
pkg: /data/local/tmp/

06-22 21:20:07.908    5072-5083/ W/zipro﹕ Unable to open zip '/data/local/tmp/': Permission denied
06-22 21:20:07.908    5072-5083/ D/asset﹕ failed to open Zip archive '/data/local/tmp/'
06-22 21:20:07.910    5072-5083/ W/PackageParser﹕ Unable to read AndroidManifest.xml of /data/local/tmp/ AndroidManifest.xml
            at android.content.res.AssetManager.openXmlAssetNative(Native Method)
            at android.content.res.AssetManager.openXmlBlockAsset(
            at android.content.res.AssetManager.openXmlResourceParser(
            at android.os.Binder.execTransact(
            at Method)
06-22 21:20:07.910    5072-5083/ W/DefContainer﹕ Failed to parse package
06-22 21:20:07.911      364-386/system_process W/ActivityManager﹕ No content provider found for permission revoke: file:///data/local/tmp/
06-22 21:20:08.101      364-386/system_process D/dalvikvm﹕ GC_EXPLICIT freed 90K, 16% free 47127K/55479K, paused 5ms+30ms, total 191ms
I´m able to install the apk by copying to sdcard and installing directly from Android.

Tried to change /data/local folder permissions to 755, but the issue remains.

This started to happen after:
a) Updated my Android to a custom rom
b) Updated Android Studio from 0.4.6 to 0.5.2

But since both updates were simultaneously, cant say which one is responsible for this error.

Any help is appreciated.

Using Windows 8.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes